php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20012 --enable-cli doesn't seem to work.
Submitted: 2002-10-21 09:41 UTC Modified: 2002-10-21 09:49 UTC
From: amir at abiri-e dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.2.3 OS: Linux Redhat-7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: amir at abiri-e dot com
New email:
PHP Version: OS:

 

 [2002-10-21 09:41 UTC] amir at abiri-e dot com
I read about the new cli feature and wanted to try it out. I read that it isn't on by default in versions prior to 4.3.0, so I compiled the latest version 4.2.3 (this has nothing to do with this) and added --enable-cli.
The functionality described in http://www.php.net/manual/en/html/features.commandline.php doesn't apply, plus nothing in the complition proccess seems to imply any notice to the switch, i.e I would expect the remark about the "You are compiling the CGI version of PHP without any redirection..." to not show up, or at least have some different syntax, plus perhaps some warning about cli being still in it's experimental stage.

All and all it seems that eighter I missed something (although I read the docs again and again and haven't found anything but --enable-cli) or that the complition process somehow "skipped" that switch in some way.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-21 09:49 UTC] sander@php.net
The cli ends up in ./sapi/cli/php in your sourcedir and gets installed to (I think) /usr/local/bin/php. It gets installed _together_ with another SAPI, like CGI. 4.3.0 has a --disable-cgi switch so you can install the CLI alone.
Just use 4.3.0 for full CLI support.
 [2002-10-21 09:49 UTC] edink@php.net
CLI was marked experimental in 4.2.x and is therefor not installed with "make install". You'll have to do that manually by copying sapi/cli/php from your PHP build dir to some directory in the path (/usr/bin for example).
 [2002-10-21 09:57 UTC] amir at abiri-e dot com
And the original php binary that is complied - I don't need it ? I mean I want cli only when it comes to command line, so I can remove the php binary that make install puts in my path without fear of interfering with the php apache module's work ?

Do I have to use --diable-cgi to get the cli behave exactly like the doc describes it ? or is it enough to use the cli binary ? (I have already noticed that implicit_flush isn't on by default)
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 13:01:29 2024 UTC