php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19969 file_exists() doesn't return correct results
Submitted: 2002-10-18 00:09 UTC Modified: 2002-10-18 01:02 UTC
From: aldem-php at aldem dot net Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.2.3 OS: Slackware Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aldem-php at aldem dot net
New email:
PHP Version: OS:

 

 [2002-10-18 00:09 UTC] aldem-php at aldem dot net
I upgraded my installation to Apache 2.0.43 (old was 2.0.36) and PHP 2.4.3 (old was 2.4.1), and noticed that my application doesn't work anymore. PHP is compiled as module.

Finally, I found that file_exists() function doesn't work properly. My test script:

<?php
        $e1 = file_exists("index.php");
        $e2 = is_file("index.php"); 
        echo "e1 = $e1; e2 = $e2";
?>

It's output:

e1 = ; e2 = 1

file_exists(".") always returns 1.

Nothing was changed in configuration after upgrade. I looked into source, and found that code responsible for this functionality was significantly changed, so... Perhaps this is a bug. Serious one.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-18 00:39 UTC] derick@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-10-18 01:02 UTC] aldem-php at aldem dot net
Thanks, the problem is resolved after installation of latest snapshot.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 17:01:31 2024 UTC