php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19915 ibase_query() fails but returns true
Submitted: 2002-10-15 05:43 UTC Modified: 2003-11-18 11:02 UTC
From: irie at gmx dot de Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.3.0-pre1 OS: Linux 2.4.18
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: irie at gmx dot de
New email:
PHP Version: OS:

 

 [2002-10-15 05:43 UTC] irie at gmx dot de
Hi,
dropping a table fails in interbase if there are existing dependensies for the table, i.e. if a view is using the table.

Executing such a query with the isql tool I get:

SQL> DROP TABLE SONGS;
Statement failed, SQLCODE = -607

unsuccessful metadata update
-cannot delete
-COLUMN ARTIST
-there are 1 dependencies


But executing the same query via php's ibase_query() returns TRUE :

var_dump(ibase_query($dbhandle, 'DROP TABLE SONGS'));

> bool(true)


Beside 4.3.0-pre1 I've just tested this with 4.0.6 and found the same behavior.

Lutz

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-09 22:13 UTC] abies@php.net
Because InterBase uses a transaction to process the metadata updates, the dependency conflict is not reported
before the is transaction is committed.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 05:01:22 2020 UTC