php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19897 checkdnsrr() always true
Submitted: 2002-10-14 03:42 UTC Modified: 2002-10-27 22:20 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: dietmar dot k at firemail dot de Assigned:
Status: Not a bug Package: Network related
PHP Version: 4.3.0-dev OS: Linux 2.4.18-3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dietmar dot k at firemail dot de
New email:
PHP Version: OS:

 

 [2002-10-14 03:42 UTC] dietmar dot k at firemail dot de
checkdnsrr()
I try to check a domain: ?k?dlkfdfdfklk.nooooooo

Now whatever strange kind of domain I try, the getmxrr always returns
true!

PHP 4.2.2, 4.2.3, 4.3.0-pre1
Redhat 7.3 ( 2.4.18-3).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-14 03:48 UTC] dietmar dot k at firemail dot de
see also
http://bugs.php.net/bug.php?id=8264
 [2002-10-14 03:53 UTC] sas@php.net
The problem arises due to some breakage of your particular operating system installation. It is possible for example that there is a conflict between a manually installed BIND resolver and the system headers.

This family of functions is known to work with other, similar Linux installations.

Please let us know whether you can provide a test ssh account on the affected machine.
 [2002-10-14 03:58 UTC] dietmar dot k at firemail dot de
no local BIND is installed. the commands host and nslookup work correctly.
 [2002-10-14 06:38 UTC] dietmar dot k at firemail dot de
i use glibc-2.2.5-40
it seems to be a bug.
 [2002-10-14 18:10 UTC] sniper@php.net
you mean it seems to be bug in glibc?

 [2002-10-15 02:05 UTC] dietmar dot k at firemail dot de
perhaps a bug between glibc-2.2.5-40 and php?
 [2002-10-20 23:51 UTC] sniper@php.net
updated version since this was reported to happend with 4.3.0-dev too.

 [2002-10-23 02:28 UTC] lgm2 at noos dot fr
Randomly always false for me when it's normaly true !!!
 [2002-10-27 22:20 UTC] sterling@php.net
not a php bug anyway you swing it....
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 04:01:27 2019 UTC