php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19885 @dl() causes script to exit
Submitted: 2002-10-13 05:31 UTC Modified: 2002-10-13 09:27 UTC
From: nick at macaw dot demon dot co dot uk Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.2.1 OS: NT4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
36 - 24 = ?
Subscribe to this entry?

 
 [2002-10-13 05:31 UTC] nick at macaw dot demon dot co dot uk
Ok, so dl() doesn't yet work on windows and that's fine, but it should still be possible to call dl() on that platform and have no ill effects when suppressed with @. However, whilst the resultant error message is suppressed, script execution terminates. Suppression of other errors from dl() on Unix works as expected.

Sniper: the following script will reproduce the problem.

<? @dl('bug'); echo 'gub'; ?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-13 05:58 UTC] nick at macaw dot demon dot co dot uk
In fact this is specific to threaded servers, such as Apache, and happens because the error is considered fatal. However the categorisation may be inappropriate because a script may have an appropriate handler to deal with all dl() failures, and not wish to have platform/server specific code.
 [2002-10-13 09:27 UTC] derick@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 18 05:01:23 2021 UTC