php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19860 Calling certain COM Objects causes PHP/Apache to hang
Submitted: 2002-10-11 05:48 UTC Modified: 2002-10-12 09:46 UTC
From: sanka at gxt dot net Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.2.3 OS: Windows 2000/SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sanka at gxt dot net
New email:
PHP Version: OS:

 

 [2002-10-11 05:48 UTC] sanka at gxt dot net
When calling certain com objects, like Outlook.Application, or my own custom ones compiled in Visual basic, the webserver (Apache 1.3) will hang, and needs to be restarted.

The code used was:
<begin block>

$myItem = new COM("Outlook.Application")l
$myItem = $objApp->CreateItem(olMailItem);
$a=$myItem->Recipients->Add("webmaster@here.com");
$myItem->Subject="Subject";
$myItem->Body="This is a Body Section now.....!";
$myItem->Display();

<end block>

outlook.exe did load (appeared on the process list).

but that is where it stopped.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-12 09:46 UTC] phanto@php.net
1.) if apache is running under a different user (system, apache, whatever ...) outlook will run as that user and therefor might run the first time for that user prompting for user input (creating an email account and so on)
2.) doing UI things as a server is not a good thing(tm) because you don't see what's going on

if php also hangs when you execute your script from the command line then reopen this report.

harald
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 22:05:43 2022 UTC