php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19829 form array variables get trimmed
Submitted: 2002-10-09 04:02 UTC Modified: 2002-10-09 04:05 UTC
From: emh at poczta dot fm Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.2.3 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: emh at poczta dot fm
New email:
PHP Version: OS:

 

 [2002-10-09 04:02 UTC] emh at poczta dot fm
i have a form with input fields declared like this:
<input type="text" name="p[]">
ie. form variables are returned in array 'p'. the problem is that returned values get cut their first four characters off. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-09 04:05 UTC] derick@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 [2002-10-10 13:23 UTC] speedfreak50 at netscape dot net
If this was not a large fix, is it possible for you to post what changes were required so they can be integrated into 4.2.3 until the next version is released?

If you can do that it would be very (very, very ;>) much appreciated.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 11:01:23 2020 UTC