php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19828 zlib-compression (gzip encoding) don't work with any browser
Submitted: 2002-10-09 03:49 UTC Modified: 2002-10-09 12:21 UTC
From: paolo at ir3ip dot net Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.2.3 OS: linux 2.2.19
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paolo at ir3ip dot net
New email:
PHP Version: OS:

 

 [2002-10-09 03:49 UTC] paolo at ir3ip dot net
Hi all.
I've stated that zlib-compression feature is not correctly implemented, because the HTML header must be something like this:

.....
Content-type: text/html
Content-encoding: gzip


Now, php zlib-compression feature don't work with IE, Konqueror, and probably other few browsers, because it send "Content-encoding: gzip" BEFORE "Content-type: mimetype".

Bytheway, the zlib compression is a good enhancement for those who are not using mod_gzip module.

Ok, good luck. Paolo

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-09 12:21 UTC] iliaa@php.net
This works fine in IE 6.0, Mozilla, Konqueror and Opera I imagine it works in other browsers as well since the order of headers in this particular case does not make a difference.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 01 05:01:24 2020 UTC