php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19816 pfpro modules fails 'nm' test on valid lib
Submitted: 2002-10-08 09:47 UTC Modified: 2002-10-09 19:41 UTC
From: chris at lodo dot net Assigned:
Status: Closed Package: Verisign Payflow Pro related
PHP Version: 4.2.3 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chris at lodo dot net
New email:
PHP Version: OS:

 

 [2002-10-08 09:47 UTC] chris at lodo dot net
In 'configure' on PHP version 4.2.3, the version check for Payflow Pro will fail on Solaris.  The problem is that configure looks to column 3 of nm's output, which works fine in Linux, but in Solaris' version of 'nm', the output is different.

nm outputs this:
#nm libpfpro.so | grep pfproInit
[3527]  |    154896|      32|FUNC |GLOB |0    |12     |pfproInit

So the pfpro functions print in column 8, preceeded by a '|' character.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-09 19:41 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 17:03:35 2021 UTC