php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19814 cannot load php_curl.dll, but it is there
Submitted: 2002-10-08 07:55 UTC Modified: 2002-10-08 08:17 UTC
From: akorthaus at web dot de Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.2.2 OS: Windows2000 SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akorthaus at web dot de
New email:
PHP Version: OS:

 

 [2002-10-08 07:55 UTC] akorthaus at web dot de
I(and many others too) have got the same problem as mentioned in http://bugs.php.net/bug.php?id=19591.

I'm running PHP 4.2.2 with Apache 2 on Win2000 SP3 and I _have_ an
original winnt\system32\msvcr70.dll, perhaps form SP3. I also have the
php_curl.dll in the correct folder, all other modules work well this
way! I also have the "real" curl run on my computer, therefore I needed
the other required dlls in system32 folder, so if curl works, php_curl
should work too! I also copied all related dlls into serveral folders, but nothing worked. I think this _is_ a PHP-bug! I get the same error as described
in the following:

<quote from php-manual:
http://www.php.net/manual/en/ref.curl.php#AEN9715>
orangevwbus at yahoo dot com
05-Jan-2002 08:12
In win32 (Windows 2000), I couldn't get apache to start with PHP/curl
support 'cause it said it couldn't find the php_curl.dll. Well it was
there.
MSVCRT.dll was there as well, but after I ran the dll through "Depends",
there's a new DLL for the Microsoft .NET stuff. It's called msvcr70.dll,
and without it, php_curl.dll won't load.
I didn't want to load .NET framework on my machine (which
msdn.microsoft.com suggested)
I did a google search and found a downloadable copy of the file and
threw it in my %system%\system32 folder and all the lights and whistles
came on.
d dot kingma at ContentS dot nl
30-Jan-2002 08:47
in addition to the files named above, you should also add the file
libeay32.dll to your PHP directory. The file can be found in the dlls
directory
</quote from php-manual>

And please have a look at
http://curl.haxx.se/mail/archive-2001-05/0058.html 

rgds
Andreas

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-08 08:16 UTC] edink@php.net
Just follow the install instructions and copy files from "dlls" folder in you c:\winnt\system32 dir.
 [2002-10-08 08:17 UTC] edink@php.net
That should be: "to your c:\winnt\system32 dir".
 [2004-07-09 20:29 UTC] dmgreer at airmail dot net
I had this same problem on the same kind of system: PHP 4.2.2 with Apache 2 on Win2000 SP3. What finally fixed it for me was loading libeay32.dll and ssleay32.dll into c:\winnt\system32. When I restarted Apache with just libeay32.dll, it complained that it couldn't find ssleay32.dll, so I just copied that from my PHP/dlls directory too and then it worked.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 10:01:32 2019 UTC