|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19776 recode is "silent"
Submitted: 2002-10-06 04:55 UTC Modified: 2003-07-24 22:35 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: root at velenje dot cx Assigned:
Status: Not a bug Package: Recode related
PHP Version: 4.2.3 OS: redhat 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: root at velenje dot cx
New email:
PHP Version: OS:


 [2002-10-06 04:55 UTC] root at velenje dot cx
I have compiled php 4.2.3 on redhat 8.0 with       
-----php configure CGI---     
./configure  --with-mysql=/usr --enable-sysvsem     
--enable-sysvshm --with-gd=yes --with-zlib --with-ttf     
--with-zlib-dir=/usr --with-gd-dir=/     
usr/ --with-jpeg-dir=/usr/lib/ --enable-gd-imgstrttf     
--with-config-file-path=/etc/httpd/conf/ --enable-trans-sid     
--with-png-dir=/usr/ --with     
-sablot --with-recode --with-curl --with-openssl     
The dso is the same one it just has --with-apxs added and the     
results are the same on cgi and dso     
All compiles fine php runs ok but when i try to use an recode     
function from php script  it doesnt do anyhing.    
so an test line containing only   
 'echo recode("../qp","sas=32");'   
 doesnt return anything. I have an old working system with   
4.0.6 and recode 3.5  which returns what it should [thats  
Recode it self works in the shell  
[tmp]#cat recode.txt 
recode ../qp recode.txt 
[tmp]# cat recode.txt 
i tried also making an error [i didn`t suply any parameters to 
the function] and it warns me  with "... 
 Wrong parameter count for recode() in ..."  
I tried with recode rpm from redhat, i tried mine [compiled it my 
self] no diffrence it just doesnt return anything.  


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-06 14:26 UTC]
Which recode library are you using now? There seems to be a problem with recode 3.6, since all string based functions always return blank string.
 [2002-10-06 14:29 UTC] root at velenje dot cx
Right now i`m  using 3.6.  
3.5 does not compile and run on rh 8.0 [it seg faults even in 
the shell]. i did not how ever put a lot of effort into the 
compiling of 3.5.
 [2002-10-21 03:25 UTC] thomas at unifiedconsulting dot com
FYI, on RH7.3 with PHP 4.2.3 and Recode 3.6 (recode-devel-3.6-6 RPM), many recode calls from PHP return blank, but strangely latin1..flat (and maybe others, I just happen to be using that one) returns the string with a trailing 'control-@'
 [2002-10-22 09:11 UTC]
After doing tests on the recode 3.6 library, it appears that only file_to_file API function works properly. Since that function is not even used by PHP, I am guessing we'll need to wait for the next recode library release before this problem can be addressed.
 [2003-07-24 22:35 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This is an issue with the recode library and not PHP itself. For now use iconv, which works perfectly.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 11:01:30 2024 UTC