php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19710 var_unserializer.c comparison always false?
Submitted: 2002-10-02 06:08 UTC Modified: 2002-10-02 10:52 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: allard at byte dot nl Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4.2.3 OS: SunOS baco 5.8 Generic_108528-13
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: allard at byte dot nl
New email:
PHP Version: OS:

 

 [2002-10-02 06:08 UTC] allard at byte dot nl
./configure     --with-apxs=/usr/local/apache/bin/apxs \
                --enable-versioning \
                --with-mysql=/usr/local \
                --with-gd \
                --with-jpeg-dir=/usr/local \
                --with-png-dir=/usr/local \
                --with-zlib-dir=/usr/local \
                --enable-ftp


/bin/sh /backup/src/php/php-4.2.3/libtool --silent --mode=compile gcc  -I. -I/backup/src/php/php-4.2.3/ext/standard -I/backup/src/php/php-4.2.3/main -I/backup/src/php/php-4.2.3 -I/usr/local/apache/include -I/backup/src/php/php-4.2.3/Zend -I/usr/local/include -I/usr/local/include/mysql -I/backup/src/php/php-4.2.3/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=280 -DMOD_SSL=208109 -DEAPI -I/backup/src/php/php-4.2.3/TSRM -g -O2 -prefer-pic  -c var_unserializer.c
var_unserializer.c: In function `php_var_unserialize':
var_unserializer.c:308: warning: comparison is always false due to limited range of data type

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-02 06:10 UTC] allard at byte dot nl
Additional info the system clipped off the OS textbox :)

SunOS baco 5.8 Generic_108528-13 sun4u sparc

That's 64 bits computing.

Please mail me if you need any specific compiler outputs or specs.
 [2002-10-02 10:52 UTC] sander@php.net
var_unserializer.c is a generated file (using re2c). We can't do much about it, and it's not necessary to.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 09:02:33 2020 UTC