php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19695 Access Violation Errors
Submitted: 2002-10-01 13:16 UTC Modified: 2002-10-05 01:37 UTC
From: nick at axelis dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.2.3 OS: NT 4.0 SP6a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nick at axelis dot com
New email:
PHP Version: OS:

 

 [2002-10-01 13:16 UTC] nick at axelis dot com
The system has been running great for a few weeks. Starting yesterday I got an access violation error on one of mysites. I was able to reboot the server and it went away. Today I have two php sites that have a consistent access violation error. I've looked through the bug reports and found many reported bugs involving this error, mostly on older versions of php4. What I could not find is any referance to what may actually be causing this error. My phpMyAdmin works so It's most likely not a MySQL problem. You can see the problem here: http://icesource.com/forum/index.php. I'm running php4isapi.dll. I would prefer to run the CGI, but whenever I do it just throws erros all over the screen. I'm not a developer and don't have time to track down hundreds of errors. Please advise.

Nick

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 18:13 UTC] iliaa@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2002-10-02 10:37 UTC] nick at axelis dot com
Why is every single item on the bug list regarding this error responded to with nothing of consequence? There is already more than enough information on this subject in the bug list to write a doctoral thesis on the subject. Why does the ISAPI implementation of PHP cause this problem? What is this error? What is it trying to access that causes this violation? What is the nature of the violation? This is obviously a widespread problem affecting Win32 ISAPI in PHP in general. When, if ever, is it going to be addressed? Why is PHP distributed with a configuration suitable only for development? There are a lot of us out here who just want to use it. That number is quickly, if it hasn't already, becoming the majority of PHP users. Now that I've finally tracked down the root cause of the problems I was having with PHP CGI I don't need to use the ISAPI module. Still, I think it would be nice if you guys would solve the problem instead of deflecting the bug reports or ignoring requests for help on the subject in the mailing list. It is a bug. There are too many reports of it here to be ignored. PHP needs to get serious about error documentation. It needs to decide if it wants to market only to developers, or to all webmasters. If you're only going to market to developers, the developers are going to have a serious problem. I'm not going to use an application that I need to be a developer to use. For the past 3 years or so I have not purchased some PHP applications I wanted to use becasue they were a superior solution. Why didn't I purchase them? Becasue I couldn't get PHP to work properly on my server. It's taken me three years to get this right becasue of the tons of documentation and information out there on PHP I could find nothing that addressed the problems I was having. All of my questions went unanswered. Any product, even a free one, isn't worth the price if it doesn't work!
 [2002-10-02 10:41 UTC] rasmus@php.net
PHP works just fine for non-developers on production quality server operating systems.  Debugging ISAPI issues is nearly impossible due to the closed blackbox nature of that environment.  If you feel there is so much info about it, then by all means, fix the problem.  Obviously that is not the case.  If we knew what the problem was, we would fix it.
 [2002-10-05 01:37 UTC] iliaa@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


Your original report, nor the subsequent report had provided us with any meaningful data that would permit us to replicate the problem.
As the bug reporting guide suggests, if you want a bug to be solved, make it easy for developers to track down the problem by providing backtraces and/or small sample scripts.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 05 17:01:16 2020 UTC