php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19679 installation of packages fails pear 1.32.2.2
Submitted: 2002-09-30 15:57 UTC Modified: 2002-10-20 23:26 UTC
From: wessel at louwris dot nl Assigned:
Status: No Feedback Package: PEAR related
PHP Version: 4.2.2 OS: linux 2.4 - debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wessel at louwris dot nl
New email:
PHP Version: OS:

 

 [2002-09-30 15:57 UTC] wessel at louwris dot nl
Installing packages with dependencies without version numbers (like mdb, depends on XML_Parser, but not on a specific version), the installation proces fails: 

pear -v install http://pear.php.net/get/mdb
...
    Relation 'has' with requirement '' is not supported
...

If I look in Dependency.php,v 1.5.2.1 , function checkPackage does not have a case where it accepts a requirement without version number.

So I think all package.xml files need to be updated, or the function needs a line which accepts a dependency without requirement (that's what I changed in my version). Or maybe my version is out of date anyway?

Wessel

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-02 10:44 UTC] sander@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-20 23:26 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-11-26 16:08 UTC] csnyder at 1msg dot com
I see this same error on SUSE 8.0 Pro.

I have a problem with the php version
when I run:
>php -v i
I get 4.1.0
However when I do phpinfo() from a php page and my apache web server I get php version 4.2.1

I changed the checkPackage function in Dependency.php,v 1.5.2.1 to get around this error. Let me know if I can be of further help.
Chris
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 02:05:51 2022 UTC