php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19634 Mapping of .html and .htm files fails
Submitted: 2002-09-27 06:35 UTC Modified: 2003-01-16 01:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: chris at owta dot net Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.2.3 OS: Windows 2k SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chris at owta dot net
New email:
PHP Version: OS:

 

 [2002-09-27 06:35 UTC] chris at owta dot net
Mapping .html and .htm files to the php.exe file in 4.2.3 returns "The directory name is invalid" when trying to run a .html file.

.html and .htm have been mapped to ASP and work correctly, it is with this latest version of PHP that this error occurs.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-27 06:44 UTC] cynic@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2002-09-27 07:40 UTC] chris at owta dot net
This is with IIS 5 on windows 2000. It is a virtual directory that the file extensions are being mapped to. The setup version of PHP was the setup.exe file.

For this website I went to the properties->home directory->configuration->app mappings and added a new .html mapping to php.exe in my php directory.

Php is installed at c:\php

In my php.ini file i have aside from the default settings:
cgi.force_redirect = 0
extension_dir = C:/PHP/extensions
display_errors = Off
error_log = syslog
extension=php_mssql.dll
 [2002-09-27 07:41 UTC] chris at owta dot net
"It is a virtual directory that the
file extensions are being mapped to"

should read "Website" not virtual directory, that the file extension is being mapped to (rather than it being global accross all websites)
 [2002-11-30 20:53 UTC] kimihia@php.net
Is this an IIS problem or a PHP problem?
 [2002-12-01 11:40 UTC] chris at owta dot net
Mapping .html to ASP works so i'm assuming it's a problem with PHP and IIS
 [2002-12-31 04:25 UTC] k.schroeder@php.net
Please try PHP 4.3.0.
 [2003-01-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-04-17 07:34 UTC] piech at piechdesign dot com
I encountered this problem also with PHP 4.3.1 on XP Pro with IIS 5.

I was NEVER able to get the CGI version of PHP to stop giving this error.

However, when I changed over to the ISAPI version of PHP everything seems to be working fine.

It's not a solution to the CGI Problem, but at least now I can develop.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 08:03:38 2021 UTC