php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19599 "driver initialization failed" on any "driver"
Submitted: 2002-09-25 13:34 UTC Modified: 2003-03-13 15:05 UTC
From: ivoras at fer dot hr Assigned: helly (profile)
Status: Not a bug Package: DBM/DBA related
PHP Version: 4.2.3 OS: Linux (Debian 3)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ivoras at fer dot hr
New email:
PHP Version: OS:

 

 [2002-09-25 13:34 UTC] ivoras at fer dot hr
Running php with db3 and db2 and gdbm causes all dba_* functions to fail with "driver initialization failed" error regardless of which driver is used.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-25 17:11 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2003-03-10 03:00 UTC] b0nks at nerim dot net
I got the same error whatever dba_* function i use: i have tested on

Windows XP / PHP 4.2.0
Linux GNU Debian / PHP 4.1.2
Linux GNU Debian / PHP 4.3.1

dba support is enabled in all versions refering to phpinfo();
 [2003-03-10 17:12 UTC] helly@php.net
For a first start please only use db2 OR db3 support.
If this doesn't help disable ndbm also. Then enable flatfile and see if this works.

Since you cannot have both db2 and db3 enabled this stays bogus.
 [2003-03-13 08:52 UTC] b0nks at nerim dot net
actually i have db2 support enabled and it does not work at all, i'll try and tell you what the result is without ndbm enabled.
what do you mean "enabling flatfile"?

Did another test: on a RedHat 8 / PHP 4.3.1

same result
 [2003-03-13 14:09 UTC] helly@php.net
With flatfile i mean "--enable-flatfile"

However do you use lib-d2.a or .so? 

In case of .a use the .so (it may be necessary to recompile db2 with "--enable-shared"). To test this use
"ldd php".
 [2003-03-13 15:05 UTC] ivoras at fer dot hr
Just to add, this was NOT a bogus report, and the problem was visible on many systems, including FreeBSD. There IS something fishy going on with the DBA module, no the least with the (absence/improper use) of record locking. My final solution was to use a custom PHP-written flat file system, until all is solved.
 [2003-03-25 08:27 UTC] b0nks at nerim dot net
well, its the same using "--enable-flatfile" with ndbm enabled or not

ivoras, another program is creating the database, so i can't change the file structure..
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 00:01:25 2019 UTC