php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19556 UPLOAD_ERR_PARTIAL when uploading files does not work, the error stays zero
Submitted: 2002-09-23 03:15 UTC Modified: 2005-01-10 15:17 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: tal at netoncourse dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.3.8 OS: win2k server & proffesional
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tal at netoncourse dot com
New email:
PHP Version: OS:

 

 [2002-09-23 03:15 UTC] tal at netoncourse dot com
UPLOAD_ERR_PARTIAL in the $_FILES array never occurs. In case of partial uploads, the error stays zero which is misleading of course.

I've used the compiled php that I've downlaoded from php.net.

I'm running the PHP SAPI module on Apcahce2 - 2.0.40

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-07 11:46 UTC] pieter at frenssen dot be
This bug has been closed but isn't fixed yet.

I'm experiencing the same problem. It is very easy to test, just do a post upload to a file containing the script

<?php
$message = print_r( $_FILES, TRUE );
mail('email@address.com','test',$message);
?>

upload a large file, press stop during the upload and check the email. It will contain the text '[error] => 0'

I'm using PHP 4.3.8 on Apache 1.3.31.
 [2004-10-09 16:19 UTC] pieter at frenssen dot be
I have solved this problem, it appears to be caused by the installation of Gzip 1.3.26.1a

I recompiled Apache without Gzip and when I now retry the error does not occur anymore. In effect the script is not executed at all which is probably the default behaviour.
 [2005-01-10 15:17 UTC] sniper@php.net
Not PHP bug.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 22 01:01:26 2019 UTC