php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19550 touch() still doesn't work
Submitted: 2002-09-22 08:32 UTC Modified: 2002-09-26 18:15 UTC
From: donald at eastcape dot net Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.x OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: donald at eastcape dot net
New email:
PHP Version: OS:

 

 [2002-09-22 08:32 UTC] donald at eastcape dot net
I see in the PHP 4.2.4-dev news.txt

- Fixed a bug that prevented touch() from working on various platforms. (Steph)

This bug is still not fixed, as tested by the following script (refreshing) :

<?php
touch("./test2");
echo filectime("./test2");
?>

Works perfectly on my linux machine, but not on my Windows machine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-22 20:29 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-09-23 00:06 UTC] donald at eastcape dot net
Hey, I tried the new snapshot, still no luck,

I am using Windows 2000, servicepack 2 on a FAT32 filesystem, if that helps..

Take a look at:

http://62.200.163.104/touchbug/
and http://62.200.163.104/touchbug/phpinfo.php

The source for the index page is the same as I mentioned in an earlier comment.
 [2002-09-23 02:23 UTC] donald at eastcape dot net
Hey sorry, I have to take my 62.200.163.104 box down today, I have saved a copy of the phpinfo() at:

http://62.200.163.98/phpinfo.htm

for you, but I can't setup the box to use 4.3.0 as its a production box atm.. sorry about this, thanks, I'll try get it back up soon though
 [2002-09-26 18:15 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

It works fine with PHP downloaded from this URL: 
http://snaps.php.net/win32/php4-win32-latest.zip

I suspect you've downloaded snapshot of the STABLE branch, which does not include the fix mentioned.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 20:04:13 2023 UTC