php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19505 PHP Make Failure
Submitted: 2002-09-19 15:33 UTC Modified: 2002-09-24 00:32 UTC
From: adsouza at globix dot net Assigned:
Status: Closed Package: OpenSSL related
PHP Version: 4CVS-2002-09-19 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adsouza at globix dot net
New email:
PHP Version: OS:

 

 [2002-09-19 15:33 UTC] adsouza at globix dot net
CC = gcc version 3.0.3
OS = Solaris 8
System = Sun Sparc Ultra Enterprise 420R
Make = GNU Make version 3.79.1
Apache = Apache 2.0.40 with SSL
SSL = OpenSSL-0.9.6g

Compiling php4-200209190600 with configure options:
/usr/local/src/php4-200209190600# ./configure \ 
? --prefix=/usr/local/apache/2.0.40/php-4.3.0dev \
? --with-apxs2=/usr/local/apache/2.0.40/bin/apxs \
? --with-oracle=/usr/local/oracle/OraHome1 \
? --with-ldap=/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris \ 
? --with-mysql=/u01/mysql \
? --with-gdbm \
? --enable-debug \
? --enable-sysvsem \
? --enable-sysvshm \
? --enable-shmop \
? --enable-dba \
? --with-zlib \
? --enable-dbx \
? --enable-trans-sid \ 
? --with-mnogosearch=/usr/local/mnogosearch \
? --enable-sigchild \
? --enable-wddx \
? --with-openssl=/usr/local/www_ssl

/usr/local/src/php4-200209190600# make
...snip
/bin/sh /usr/local/src/php4-200209190600/libtool --mode=compile gcc  -Iext/standard/ -I/usr/local/src/php4-200209190600/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209190600/include -I/usr/local/src/php4-200209190600/main -I/usr/local/src/php4-200209190600 -I/usr/local/apache/2.0.40/include -I/usr/local/src/php4-200209190600/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209190600/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209190600/TSRM  -g -O2 -pthreads -Wall -DZTS  -prefer-pic -c /usr/local/src/php4-200209190600/ext/standard/ftp_fopen_wrapper.c -o ext/standard/ftp_fopen_wrapper.lo
gcc -Iext/standard/ -I/usr/local/src/php4-200209190600/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209190600/include -I/usr/local/src/php4-200209190600/main -I/usr/local/src/php4-200209190600 -I/usr/local/apache/2.0.40/include -I/usr/local/src/php4-200209190600/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209190600/ext/xml/expat -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209190600/TSRM -g -O2 -pthreads -Wall -DZTS -c /usr/local/src/php4-200209190600/ext/standard/ftp_fopen_wrapper.c  -fPIC -DPIC -o ext/standard/ftp_fopen_wrapper.lo
/usr/local/src/php4-200209190600/ext/standard/ftp_fopen_wrapper.c: In function `php_stream_url_wrap_ftp':
/usr/local/src/php4-200209190600/ext/standard/ftp_fopen_wrapper.c:418: too few arguments to function `php_stream_sock_ssl_activate_with_method'
/usr/local/src/php4-200209190600/ext/standard/ftp_fopen_wrapper.c:143: warning: `result' might be used uninitialized in this function
make: *** [ext/standard/ftp_fopen_wrapper.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-19 20:32 UTC] kalowsky@php.net
minor comment, the openssl list has had a lengthy discussion about Apache2 and OpenSSL not working together very well.  So I'm not even sure if this is just a PHP issue... but whatever.
 [2002-09-20 07:04 UTC] adsouza at globix dot net
I have also received this issue with Apache2.0.40 not running SSL on a Sun Blade running Solaris 8.  This makes me wonder if the issue is related to SSL at all?
 [2002-09-20 09:27 UTC] adsouza at globix dot net
to test if SSL is the issue with Apache2, i built Apache2.0.40 on the same server without SSL and just with enable-so option.

Here are the results of today's cvs version of php4 (I used the same exact configure command as the initial time used with apache2+ssl):

-------------------------------
/bin/sh /usr/local/src/php4-200209200000/libtool --mode=compile gcc  -Iext/standard/ -I/usr/local/src/php4-200209200000/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209200000/include -I/usr/local/src/php4-200209200000/main -I/usr/local/src/php4-200209200000 -I/usr/local/apache/2.0.40-test/include -I/usr/local/src/php4-200209200000/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209200000/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209200000/TSRM  -g -O2 -pthreads -Wall -DZTS  -prefer-pic -c /usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c -o ext/standard/url_scanner_ex.lo
gcc -Iext/standard/ -I/usr/local/src/php4-200209200000/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209200000/include -I/usr/local/src/php4-200209200000/main -I/usr/local/src/php4-200209200000 -I/usr/local/apache/2.0.40-test/include -I/usr/local/src/php4-200209200000/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209200000/ext/xml/expat -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209200000/TSRM -g -O2 -pthreads -Wall -DZTS -c /usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c  -fPIC -DPIC -o ext/standard/url_scanner_ex.lo
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c: In function `append_modified_url':
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:107: warning: unused variable `yyaccept'
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:163: warning: label `yy10' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:162: warning: label `yy9' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:157: warning: label `yy7' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:154: warning: label `yy5' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:151: warning: label `yy3' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:150: warning: label `yy2' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:143: warning: label `yy1' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c: In function `xx_mainloop':
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:313: warning: unused variable `yyaccept'
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:370: warning: unused variable `yyaccept'
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:436: warning: unused variable `yyaccept'
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:520: warning: unused variable `yyaccept'
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:756: warning: label `yy76' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:755: warning: label `yy75' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:748: warning: label `yy72' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:696: warning: label `yy59' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:648: warning: label `yy57' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:646: warning: label `yy56' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:619: warning: label `yy47' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:569: warning: label `yy43' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:556: warning: label `yy39' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:506: warning: label `yy35' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:503: warning: label `yy33' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:496: warning: label `yy29' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:472: warning: label `yy27' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:419: warning: label `yy23' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:406: warning: label `yy19' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:361: warning: label `yy17' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:360: warning: label `yy16' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:355: warning: label `yy14' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:354: warning: label `yy13' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:349: warning: label `yy12' defined but not used
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c: In function `php_url_scanner_add_var':
/usr/local/src/php4-200209200000/ext/standard/url_scanner_ex.c:855: warning: `encoded' might be used uninitialized in this function
/bin/sh /usr/local/src/php4-200209200000/libtool --mode=compile gcc  -Iext/standard/ -I/usr/local/src/php4-200209200000/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209200000/include -I/usr/local/src/php4-200209200000/main -I/usr/local/src/php4-200209200000 -I/usr/local/apache/2.0.40-test/include -I/usr/local/src/php4-200209200000/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209200000/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209200000/TSRM  -g -O2 -pthreads -Wall -DZTS  -prefer-pic -c /usr/local/src/php4-200209200000/ext/standard/ftp_fopen_wrapper.c -o ext/standard/ftp_fopen_wrapper.lo
gcc -Iext/standard/ -I/usr/local/src/php4-200209200000/ext/standard/ -DPHP_ATOM_INC -I/usr/local/src/php4-200209200000/include -I/usr/local/src/php4-200209200000/main -I/usr/local/src/php4-200209200000 -I/usr/local/apache/2.0.40-test/include -I/usr/local/src/php4-200209200000/Zend -I/usr/local/www_ssl/include -I/usr/local/include -I/usr/local/netscape/sdk/ns-ldapsdk-411-worldwide-solaris/include -I/usr/local/mnogosearch/include -I/u01/mysql/include/mysql -I/usr/local/oracle/OraHome1/rdbms/public -I/usr/local/oracle/OraHome1/rdbms/demo -I/usr/local/oracle/OraHome1/network/public -I/usr/local/oracle/OraHome1/plsql/public -I/usr/local/src/php4-200209200000/ext/xml/expat -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/src/php4-200209200000/TSRM -g -O2 -pthreads -Wall -DZTS -c /usr/local/src/php4-200209200000/ext/standard/ftp_fopen_wrapper.c  -fPIC -DPIC -o ext/standard/ftp_fopen_wrapper.lo
/usr/local/src/php4-200209200000/ext/standard/ftp_fopen_wrapper.c: In function `php_stream_url_wrap_ftp':
/usr/local/src/php4-200209200000/ext/standard/ftp_fopen_wrapper.c:418: too few arguments to function `php_stream_sock_ssl_activate_with_method'
/usr/local/src/php4-200209200000/ext/standard/ftp_fopen_wrapper.c:143: warning: `result' might be used uninitialized in this function
make: *** [ext/standard/ftp_fopen_wrapper.lo] Error 1
-------------------------

It appears to have the same issue with ext/standard/ftp_fopen_wrapper.lo.
 [2002-09-23 21:19 UTC] adsouza at globix dot net
The CVS version from 9/22 fixes this bug.  Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 05:01:23 2020 UTC