php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19502 An automatic backup of the php.ini file?
Submitted: 2002-09-19 12:32 UTC Modified: 2002-09-22 06:55 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: nico_mittes at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.3 OS: Windows NT 5.0 build 2195
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nico_mittes at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-09-19 12:32 UTC] nico_mittes at hotmail dot com
Hello, 

This is my problem: For a few weeks now we're are using PHP and MySQL and everything is working fine. But a week ago, everything turned around (I don't know a exact time): all our PHP/MySQL-sites gave errors. So, I immediately connected to our dedicated server (Windows NT) where I searched for the php.ini file. The php.ini file was located in C:\winnt\ (this is the important one of course), but it was also located in c:\php\backup\ (I don't know the exact location, but I was sure in some backup-map in the PHP-directory. So, I searched php.ini (C:\winnt\) for the solution, I say that error_reporting was changed into E_USER_NOTICE (or E_USER_ERROR, I'm not sure). So, after this I changed it in E_ALL & ~E_NOTICE, the standard value, and everything worked fine again.

But I'm now curious about the cause of this strange situation. Is it a bug? I sure was not any of my collegues, as I am the only one that connects with the dedicated server. 

Looking forward to hear from you,
Nico Smit

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-19 13:56 UTC] derick@php.net
PHP does not do this on its own, so the problem should lie elsewhere.
Not a PHP problem -> bogus.

Derick
 [2002-09-22 06:55 UTC] nico_mittes at hotmail dot com
Hello, 

This is my problem: For a few weeks now we're are using PHP and MySQL
and everything is working fine. But a week ago, everything turned around
(I don't know a exact time): all our PHP/MySQL-sites gave errors. So, I
immediately connected to our dedicated server (Windows NT) where I
searched for the php.ini file. The php.ini file was located in C:\winnt\
(this is the important one of course), but it was also located in
c:\php\backup\ (I don't know the exact location, but I was sure in some
backup-map in the PHP-directory. So, I searched php.ini (C:\winnt\) for
the solution, I say that error_reporting was changed into E_USER_NOTICE
(or E_USER_ERROR, I'm not sure). So, after this I changed it in E_ALL &
~E_NOTICE, the standard value, and everything worked fine again.

But I'm now curious about the cause of this strange situation. Is it a
bug? It sure was not any of my collegues, as I am the only one that
connects with the dedicated server. 

Looking forward to hear from you,
Nico Smit
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 23:05:51 2022 UTC