php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19488 mysql_num_rows() randomly fails
Submitted: 2002-09-18 23:38 UTC Modified: 2002-09-19 05:41 UTC
From: chris-php at bolt dot cx Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.2.3 OS: Linux 2.4.19-pre4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chris-php at bolt dot cx
New email:
PHP Version: OS:

 

 [2002-09-18 23:38 UTC] chris-php at bolt dot cx
mysql_num_rows() is randomly failing for me on any script with any SQL query. mysql_query() doesn't return false, and mysql_error() and mysql_errno() return nothing. Happens on both 4.2.2 and 4.2.3. I checked all SQL queries that this happens with and they run fine on the database server(s). The exact error message I get is:

[18-Sep-2002 21:31:46] PHP Warning:  mysql_num_rows(): supplied argument is not a valid MySQL result resource in /www/shared/sql.lib on line 99

(taken from the error_log)

The same thing seems to be happening on bugs.php.net. When I search for something, I randomly get the following errors:

Warning: mysql_numrows(): 4 is not a valid MySQL result resource in /local/Web/sites/php-bugs-web/search.php on line 119

Warning: mysql_fetch_array(): 4 is not a valid MySQL result resource in /local/Web/sites/php-bugs-web/search.php on line 139

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-19 05:41 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-10-15 11:36 UTC] chris at luxmail dot lu
I have the same problem!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 15:05:54 2022 UTC