|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19457 Apache 1.3.26 w/OpenSSL fails to start
Submitted: 2002-09-17 15:49 UTC Modified: 2002-10-27 19:08 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: websupport at networkplus dot com Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.2.3 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: websupport at networkplus dot com
New email:
PHP Version: OS:


 [2002-09-17 15:49 UTC] websupport at networkplus dot com
We performed a basic compile on the PHP module:

  ./configure --with-apxs=/usr/local/apache/bin/apxs \
    --with-mysql --with-openssl=/usr/local/ssl
  make install

Compile and install worked successfully, reporting no errors.  However, when we updated our httpsd.conf file to include support for the .php extension (and ensured that the LoadModule statement was correct), Apache/SSL failed to start, and reported no errors in the log files (nor were there any when running direct from the command line).  The only item in the log file stated that the gcache engine had started, though it subsequently died when Apache failed to start.

We have looked through the bug list, and have been unabled to find a specific bug that looks like ours (though that may be our own blindness -- if so, we apologize).  Aside from one error relating to threads (our Apache and PHP compiles both included thread support), we saw nothing.

Does anyone have any idea as to the cause of this problem?  Any assistance will be greatly appreciated.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-17 16:39 UTC] brad at info-link dot net
I ran into this exact problem last night while trying to upgrade one of my servers.  Still not sure exactly what caused it, but the crash didn't occur for me unless Apache had SSL support (apache-ssl) enabled.  Perhaps this is caused by a SSL library conflict?  I encountered this problem on RedHat 7.1, and RedHat likes to install it's own (old) version of OpenSSL.  I haven't had enough time to tinker too much, especially since it's a production server.  However, I do have one machine with this setup working, but that is RedHat 7.3.

Anyway, the setup that doesn't work for me on RedHat 7.1 is:

OpenSSL 0.9.6g
Apache 1.3.26 + Apache-SSL 1.48
PHP 4.2.3

All are source distributions, and were downloaded fresh last night.
 [2002-09-17 17:00 UTC]
I might be mistaken..but I think I had same issue myself
once and got it fixed by making sure httpd was linked with 
libpthread..can you check if your httpd is linked with it:

ldd /usr/local/apache/bin/httpd

 [2002-09-17 18:27 UTC] websupport at networkplus dot com
Yes, it was compiled with the libpthread library.  Just for a little further info, recompiling Apache WITHOUT SSL works fine ...  We're going to try the 4.2.2 PHP compile and see if that works ...
 [2002-09-17 18:53 UTC] websupport at networkplus dot com
Compiling v4.2.2 as a .so file also failed.  Out of curiosity, is there possibly a problem with our compiler version (gcc 2.95.3)?
 [2002-09-18 19:17 UTC]
Maybe you should try mod_ssl and compile it as DSO.
I'm using that and it has always worked fine.

 [2002-10-08 21:56 UTC]
Please try using this CVS snapshot:
For Windows:

And make sure you're linking both apache and php with SAME openssl libs. Best way to make sure you're doing that is to remove all libssl.* and libcrypto.* files from your system
and the header files and reinstall openssl.

 [2002-10-27 19:08 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 13:01:27 2024 UTC