php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19409 special character
Submitted: 2002-09-14 19:39 UTC Modified: 2002-09-15 06:44 UTC
From: al at fnac dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.3 OS: XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: al at fnac dot net
New email:
PHP Version: OS:

 

 [2002-09-14 19:39 UTC] al at fnac dot net
Hdd just erased to test : same thing
Os : XP
PHP-4.2.3
Apache-2.0.40

PHP.INI with register_globals = On
HTTPD.CONF : with or without erasing all language items

Problem :
when sending a varaible as 'href=index.php?msg=$msg'.
quotes or not ('$msg',"$msg",$msg).

MY LANGUAGE IS FRENCH : IF THE VARIABLE CONTENTS 
?,?,? or special,
the Apache server make a boo boo
(INTERNAL_SERVER_ERROR).

Thak u, thank me

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-15 03:08 UTC] derick@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

You need to urlencode() (www.php.net/urlencode) your special characters.

Derick
 [2002-09-15 06:44 UTC] al at fnac dot net
I gone to Apache site end they tell to go to see php.net for problems with php.
with the 1.3.26 version of Apache no problems.
It seems to be an Apache problem.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 09 13:03:40 2023 UTC