php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19396 Online documentation is for version 4.3!
Submitted: 2002-09-13 14:11 UTC Modified: 2002-09-13 17:33 UTC
From: roland at astrofoto dot org Assigned:
Status: Not a bug Package: Website problem
PHP Version: 4.2.3 OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roland at astrofoto dot org
New email:
PHP Version: OS:

 

 [2002-09-13 14:11 UTC] roland at astrofoto dot org
The online documentation at www.php.net seems to be for version 4.3.  Look, for example, through the image functions section and you will find documentation for image types and functions which are not part of 4.2.2 and comments like "since version 4.3 ...".

Hey, I'm all for up-to-date documentation, but this is a bit much.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-13 15:17 UTC] goba@php.net
Why? We are quite happy if guys who update the code update the documentation (with respective version notes), as otherwise many times the doc update is forgotten. Those types will be available in 4.3, so the documentation is quite all right.
 [2002-09-13 15:21 UTC] goba@php.net
I also must add the point that it still includes PHP 3 related information, like developing extensions for PHP 3 or migrating to PHP 4. Our intention is to provide a single manual for all versions in use (including all OS variations). Although sometimes we have problems with this approach (eg. missing version info for newly added items) most of the time this scheme works quite well.
 [2002-09-13 17:33 UTC] roland at astrofoto dot org
I disagree, at least in part, because some of this advance documentation does not indicate that the functionality is not yet available.  An example is the documentation for getimagesize which says:

Returns an array with 4 elements. Index 0 contains the width of the image in pixels. Index 1 contains the height. Index 2 is a flag indicating the type of the image: 1 = GIF, 2 = JPG, 3 = PNG, 4 = SWF, 5 = PSD, 6 = BMP, 7 = TIFF(intel byte order), 8 = TIFF(motorola byte order), 9 = JPC, 10 = JP2, 11 = JPX, 12 = JB2, 13 = SWC, 14 = IFF. These values correspond to the IMAGETYPE constants that were added in PHP 4.3. [...]

*Some* of those image types are available in 4.2 or earlier.  It reads as if *all* of them were added in 4.3.  I've spent a chunk of today testing with 4.2.2 to see which parts are currently present and which ones are not.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 19:03:46 2022 UTC