php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1936 php4-beta1 & oracle8i
Submitted: 1999-07-31 19:23 UTC Modified: 1999-09-04 18:03 UTC
From: skaar at ita dot chalmers dot se Assigned:
Status: Closed Package: Oracle related
PHP Version: 4.0 Beta 1 OS: Solaris 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: skaar at ita dot chalmers dot se
New email:
PHP Version: OS:

 

 [1999-07-31 19:23 UTC] skaar at ita dot chalmers dot se
this is just a quick and dirty patch to get php4 to compile with Oracle8i
(8.1.5) - I just tested some basic oci-scripts and it seems to work just fine.

-- cut --
*** configure.orig      Sun Aug  1 01:05:23 1999
--- configure   Sun Aug  1 01:05:40 1999
***************
*** 7143,7148 ****
--- 7143,7152 ----
    then
        ORACLE_VERSION=`grep '"ocommon"' $ORACLEINST_TOP/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 
6 | cut -c 2-4`
      test -z "$ORACLE_VERSION" && ORACLE_VERSION=7.3
+   # for Oracle8i
+   elif test -f "$ORACLEINST_TOP/install/unix.rgs"
+   then
+         ORACLE_VERSION=`grep rdbms $ORACLEINST_TOP/install/unix.rgs | sed 's/[ ][ ]*/:/g' | cut -d: -f 
2 | cut -c 1-3`
    else
      ORACLE_VERSION=8.0
    fi
***************
*** 7226,7231 ****
--- 7230,7248 ----
        else
          ORACLE_SHLIBS="$ORACLE_STLIBS"
        fi
+         ;;
+       8.1)
+         if test -f $ORACLEINST_TOP/$ORACLE_LIBDIR/libclntsh.s? -o \
+                 -f $ORACLEINST_TOP/$ORACLE_LIBDIR/libclntsh.a # AIX
+         then
+           if test "$CC" = "gcc" -a "`uname -sv`" = "AIX 4"; then
+             # for Oracle 8 on AIX 4
+             ORA_SYSLIB="$ORA_SYSLIB -nostdlib /lib/crt0_r.o /usr/lib/libpthreads.a /usr/lib/libc_r.a -l
gcc"
+           fi
+           ORACLE_SHLIBS="-lclntsh -lpsa8 -lcore8 -lnls8 -lclntsh $ORA_SYSLIB"
+         else
+           ORACLE_SHLIBS="$ORACLE_STLIBS"
+         fi
          cat >> confdefs.h <<\EOF
  #define HAVE_OCI8 1
  EOF
***************
*** 7637,7642 ****
--- 7654,7663 ----
    then
        ORACLE_VERSION=`grep '"ocommon"' $ORACLEINST_TOP/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 
6 | cut -c 2-4`
      test -z "$ORACLE_VERSION" && ORACLE_VERSION=7.3
+   # for Oracle8i
+   elif test -f "$ORACLEINST_TOP/install/unix.rgs"
+   then
+         ORACLE_VERSION=`grep rdbms $ORACLEINST_TOP/install/unix.rgs | sed 's/[ ][ ]*/:/g' | cut -d: -f 
2 | cut -c 1-3`
    else
      ORACLE_VERSION=8.0
    fi
***************
*** 7720,7725 ****
--- 7741,7759 ----
        else
          ORACLE_SHLIBS="$ORACLE_STLIBS"
        fi
+       ;;
+       8.1)
+         if test -f $ORACLEINST_TOP/$ORACLE_LIBDIR/libclntsh.s? -o \
+                 -f $ORACLEINST_TOP/$ORACLE_LIBDIR/libclntsh.a # AIX
+         then
+           if test "$CC" = "gcc" -a "`uname -sv`" = "AIX 4"; then
+             # for Oracle 8 on AIX 4
+             ORA_SYSLIB="$ORA_SYSLIB -nostdlib /lib/crt0_r.o /usr/lib/libpthreads.a /usr/lib/libc_r.a -l
gcc"
+           fi
+           ORACLE_SHLIBS="-lclntsh -lpsa8 -lcore8 -lnls8 -lclntsh $ORA_SYSLIB"
+         else
+           ORACLE_SHLIBS="$ORACLE_STLIBS"
+         fi
          cat >> confdefs.h <<\EOF
  #define HAVE_OCI8 1
  EOF
-- cut --

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-09-04 18:03 UTC] sr at cvs dot php dot net
The Oracle 8i detection of PHP3 is now in the latest PHP4 cvs,
try it and if it doesn't work for you, submit a new bug report, please.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 16:03:37 2021 UTC