php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19331 Datetime formatting problem
Submitted: 2002-09-10 06:21 UTC Modified: 2002-09-10 06:25 UTC
From: abay at siyahkale dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.2.0 OS: WIN2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: abay at siyahkale dot com
New email:
PHP Version: OS:

 

 [2002-09-10 06:21 UTC] abay at siyahkale dot com
I have PHP 4.2.0 installed on my WIN2K (Turkish Edition) server and I use SQL 7.0 Enterprise Edition. 

When I get data by query and try to format data as:

$result=mssql_query("select * from table")
while($row=mssql_fetch_object($result)) {
   $Mydate=date("d.m.Y",$row->Date_field);
   ....
   ....

}

unexpected error occurs because datafield's value comes as
13 Oca 2001 00:0  ( Oca means  Januar in Turkish ) but I need it as 13/01/2002 for global application.

I know why, but I can't find why? 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-10 06:25 UTC] cynic@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 19:01:29 2024 UTC