php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19330 Variables not present
Submitted: 2002-09-10 05:55 UTC Modified: 2002-09-10 05:56 UTC
From: tenorwoody85 at aol dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.3 OS: WinXP Home
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tenorwoody85 at aol dot com
New email:
PHP Version: OS:

 

 [2002-09-10 05:55 UTC] tenorwoody85 at aol dot com
Hi,

When I send a variable through POST or GET (eg. index.php?var=hello) the variable is not present at all in the script.  It just ceases to exist.

For example:

If in my script i wrote:
echo $var;

index.php?var=hello should say the word "hello" but NOTHING happens!  All of my scripts have ceased to function on my local server because of this.

I am using Apache 2.0 (stable release) and Internet Explorer 6 Sp1.

Many thanks
-james

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-10 05:56 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 [2002-09-10 06:10 UTC] tenorwoody85 at aol dot com
Thanks, its working now.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 07:05:45 2022 UTC