|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19232 When Load apache I get symbol __cmpdi2: referenced symbol not found
Submitted: 2002-09-04 13:04 UTC Modified: 2002-09-04 13:24 UTC
From: tbelote at mac dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.2.2 OS: Solaris 8 Sparc
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: tbelote at mac dot com
New email:
PHP Version: OS:


 [2002-09-04 13:04 UTC] tbelote at mac dot com
I configured PHP by running:
./configure --prefix=/usr/local/php-4.2.2 --with-mysql=/
usr/local/mysql --with-apxs=/usr/local/apache_1.3.26/bin/

I have also tried --with-pic

PHP was compiled using gcc 2.95.3. I am trying to use it as 
a shared module with apache 1.3.26 + mod_perl and mod_ssl. 

When I run apachectl I get:
# ./apachectl start
Syntax error on line 236 of /usr/local/apache_1.3.26/conf/
Cannot load /usr/local/apache_1.3.26/libexec/ 
into server: /usr/local/apache_1.3.26/bin/httpd: 
fatal: relocation error: file /usr/local/apache_1.3.26/
libexec/ symbol __cmpdi2: referenced symbol not 
./apachectl start: httpd could not be started


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-04 13:11 UTC]
Just add --enable-libgcc to your configure line and it should be okay. (this bug is fixed in CVS)

 [2002-09-04 13:24 UTC] tbelote at mac dot com
thanks that worked perfectly.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 00:01:29 2024 UTC