php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19038 apache 2.0.40 cannot load module libphp4.so
Submitted: 2002-08-22 06:19 UTC Modified: 2002-08-28 12:07 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: emanuele dot lombardi at casaccia dot enea dot it Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4CVS-2002-08-22 OS: COMPAQ tru64 5.1A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: emanuele dot lombardi at casaccia dot enea dot it
New email:
PHP Version: OS:

 

 [2002-08-22 06:19 UTC] emanuele dot lombardi at casaccia dot enea dot it
php 4.2.3-dev (dhp4-STABLE-200208220000) works properly used by APACHE 1.3.22 but not by Apache 2.0.40 (which without the "LoadModule php4_module modules/libphp4.so"
line in httpd.conf works perfectely)

Configuring php for apache-2.0.40 results in a 
apache-2.0.40 not starting but issuing the following output:

Cannot load /usr/local/apache-2.0.40/modules/libphp4.so into server: dlopen: /usr/local/apache-2.0.40/modules/libphp4.so: symbol "__pthread_self" unresolved

I tried setting the LD_LIBRARY_PATH to /usr/slib which is where the libpthread.so is located, but the error still exists.


Can you help me?
Thanks from Italy,

Emanuele Lombardi




Hardware: COMPAQ Alpha server 
OS:       COMPAQ Tru64 Cluster 5.1A
cc:       Compaq C V6.4-215 (dtk)

APACHE:   2.0.40 configured as follows:
          ./configure --prefix=/usr/local/apache-2.0.40 --enable-mods-shared=most 

PHP4:     php4-STABLE-200208220000 configured as follows:
           ./configure  --with-mysql --with apxs2=/usr/local/apache-2.0.40/bin/apxs --with-pdflib=/usr/local/pdflib --with-jpg-dir==usr/lo
cal/lib --with-tiff-dir=/usr/local/lib --with-png-dir=/usr/local/lib --with-zlib-dir=/usr/local/lib --prefix=/usr/local/php4-STABLE-200208220000 --with-java=/usr/opt/java130
 

Please note that Apache-2.0.40 without php4 works very well.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-23 10:16 UTC] emanuele dot lombardi at casaccia dot enea dot it
Solved!  simply 

     setenv CFLAGS -pthread

before configuring and making both apache and php

It worked with 
          apache-2.0.40
          php4-STABLE-200208220000 

          Hardware: COMPAQ Alpha server 
          OS:       COMPAQ Tru64 Cluster 5.1A 2nd patch
          cc:       Compaq C V6.4-215 (dtk)


Bye bye

Emanuele Lombardi
 [2002-08-23 10:20 UTC] georg@php.net
Which mysql client library version do you use?

Can you try to use the embedded libmysql (you don't need any configuration options for).
 [2002-08-23 10:24 UTC] emanuele dot lombardi at casaccia dot enea dot it
Mysql server is version: 3.23.40

I'm quite new to php, what can I do to solve your question about the client version ?
 [2002-08-23 10:37 UTC] emanuele dot lombardi at casaccia dot enea dot it
I now used mysql from inside php and they both work properly. Php was configured without any path given
to --with-mysql 

Mysql 3.23.40
php4-STABLE-200208220000 
apache 2.0.40
 [2002-08-23 11:06 UTC] emanuele dot lombardi at casaccia dot enea dot it
Now I close the bug.
For any further info please mail me.

Emanuele
 [2002-08-28 12:07 UTC] kalowsky@php.net
marking as closed per user request
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 16:03:36 2021 UTC