php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19001 "c-client built with SSL" - claim may be a red herring
Submitted: 2002-08-20 18:08 UTC Modified: 2003-01-18 01:05 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: vlb at gene dot com Assigned:
Status: Wont fix Package: IMAP related
PHP Version: 4.2.2 OS: Tru64 Unix
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vlb at gene dot com
New email:
PHP Version: OS:

 

 [2002-08-20 18:08 UTC] vlb at gene dot com
Running configure for build snapshot php4-200208190900 I got this message:

checking whether IMAP works... configure: error: This c-client library is build with SSL support. 
      
      Add --with-imap-ssl<=DIR> to your configure line. Check config.log for details.

In actual fact, my c-client library is NOT built with SSL support (p.s. note typo in configure; that shoukd be "built"nt "build").

The configure code first compiles, then _runs_ configtest. In this case, the compile succeeded, the run failed. I never was shown the error, which was

resolve_symbols: loader error: dlopen: libkrb5.so.3: symbol "clua_getaliasaddress" unresolved


This has nothing to do with SSL support. clua_getaliasaddress is a function found in libclua - a Tru64 cluster library.

User should be shown the actual error that configure uses to determine problems; the log should cntain error messages as well as comments from configure. (I wasted a lot of time thinking I needed SSL stuff when the problem was much simpler than that). 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-20 18:11 UTC] rasmus@php.net
Not sure we can fix that at our level.  You are asking for more of a basic change in how autoconf operates.  But perhaps there is something we can do.  We can have a look.
 [2002-08-20 19:11 UTC] kalowsky@php.net
Corrected english mistakes, thank you.  

But I don't believe that the other parts of this can be fixed.  I'll check back in on this though.
 [2003-01-18 01:05 UTC] sniper@php.net
Pretty impossible to fix from our part, except for
leaving the checks out altogether which we will not do.
(they work for most users just fine)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 06:01:23 2020 UTC