php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18998 vars using get wont print
Submitted: 2002-08-20 17:32 UTC Modified: 2002-08-20 21:26 UTC
From: trolldude at gmx dot net Assigned:
Status: Closed Package: URL related
PHP Version: 4.2.2 OS: win2k / linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: trolldude at gmx dot net
New email:
PHP Version: OS:

 

 [2002-08-20 17:32 UTC] trolldude at gmx dot net
hi,

my isp updated to php 4.2.2

since then all my scripts worked fine, as they should.
after the update nothing worked anymore.

here sample script
test.php
--------
<?php
$test = 1;
echo ("<a href=./test2.php?var=".$test.">test</a>");
?>

test2.php
---------
<?PHP
echo $var;
?>

so test2.php echoed nothing.
i tried a lot and after installing php 4.2.2 locally, ich found out that in php.ini following lines were commented out:

;;;;;;;;;;;;;;;;;
; Data Handling ;
;;;;;;;;;;;;;;;;;
;
; Note - track_vars is ALWAYS enabled as of PHP 4.0.3
; The separator used in PHP generated URLs to separate arguments.
; Default is "&".
;arg_separator.output = "&amp;"
; List of separator(s) used by PHP to parse input URLs into variables.
; Default is "&".
; NOTE: Every character in this directive is considered as separator!
;arg_separator.input = ";&"


after activating arg_seperator.output + input 
all my scripts worked fine again.

so MY problem now is that my i cant fix it locally but i and i think a lot of more people cant chang php.ini on my ISP Site.

is it possible to make this public somewhere on php.net so that also the ISPs will read when downloading ?

thanx

Markus Brendler


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-20 21:26 UTC] sniper@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 [2004-08-19 19:12 UTC] nospam at imaginacolombia dot com
you must use the $_GET and $_POST arrays, in test2.php try

<?php
echo $_GET["var"];
?>

http://www.imaginacolombia.com
 [2021-04-06 10:19 UTC] git@php.net
Automatic comment on behalf of 
Revision: https://github.com/php/pecl-system-expect/commit/3df1f5db6572fdc0157c58ea53c171b8325af736
Log: Fixed bug #18998 (Change expect.logfile on runtime leave file descriptor opened)
 [2021-04-06 10:19 UTC] git@php.net
-Status: Not a bug +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 07:03:34 2021 UTC