php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18983 compiling failure for xslt
Submitted: 2002-08-20 08:34 UTC Modified: 2002-08-20 08:43 UTC
From: luoy at muohio dot edu Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4CVS-2002-08-20 OS: solaris 2.6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: luoy at muohio dot edu
New email:
PHP Version: OS:

 

 [2002-08-20 08:34 UTC] luoy at muohio dot edu
We tried the latest version and 4.1.2.  Here is the error message. Thanks.

#./configure  --without-mysql --with-oci8 --with-apxs=/usr/local/apache/bin/apxs --with-ldap=/usr/local --enable-xslt --with-xslt-sablot=/usr/local --with-iconv --with-ssl=/usr/local/ssl --enable-libgcc
...

#make
...
ld: fatal: symbol `zm_info_xslt' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_log' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_process' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_free' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_base' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_scheme_handlers' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_encoding' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_errno' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_error' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_sax_handlers' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `xslt_module_entry' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `xslt_functions' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_create' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zif_xslt_set_error_handler' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: symbol `zm_startup_xslt' is multiply defined:
        (file ext/xslt/.libs/libxslt.al(xslt.lo) and file ext/xslt/.libs/libxslt.al(sablot.lo));
ld: fatal: File processing errors. No output written to .libs/libphp4.so
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/home/luoy/src/php-4.1.2'
make: *** [all-recursive] Error 1
[luoy@admsol03:/home/luoy/src/php-4.1.2]$

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-20 08:43 UTC] edink@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 22:01:23 2020 UTC