php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18977 mperson
Submitted: 2002-08-19 22:24 UTC Modified: 2002-08-19 23:09 UTC
From: mperson at 10mail dot net Assigned:
Status: Not a bug Package: *URL Functions
PHP Version: 4.2.2 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mperson at 10mail dot net
New email:
PHP Version: OS:

 

 [2002-08-19 22:24 UTC] mperson at 10mail dot net
I don't know whether it is a bug. I report it to you.
I installed php4.2.2 on linux2.4
complied it with "  ./configure --with-mysql  --with-apache=/usr/local/apache    --with-config-file-path=/usr/local/apache/conf 
--enable-debug=no     --enable-track-vars  "
Then I wrote a file named "test.php"
<?echo $id?> 
Test php
I write "http://****/test.php?id=abc in the address of IE
It would display "abc" but it display nothing.
I think that it could not translate the value of id.
Please tell me why?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-19 22:49 UTC] alan_k@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 [2002-08-19 23:09 UTC] mperson at 10mail dot net
Thanks a lot ,The problem is solved
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 00:03:39 2021 UTC