php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18957 multiple definitions
Submitted: 2002-08-17 09:55 UTC Modified: 2002-08-17 13:04 UTC
From: pisi at pisitek dot com Assigned:
Status: Wont fix Package: Apache2 related
PHP Version: 4CVS-2002-08-17 OS: linux 2.4.14, debian unstable
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
26 - 25 = ?
Subscribe to this entry?

 
 [2002-08-17 09:55 UTC] pisi at pisitek dot com
when compiling for apache 2.0.40 with sablotron support:
url -lssl -lcrypto -ldl -lxml2 -ldl
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/.libs/libxslt.al(sablot.lo): In function `zm_startup_xslt':
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/sablot.c:154: multiple definition of `SXPF_DISPOSE_NAMES'
main/.libs/libmain.al(internal_functions.lo):/usr/src/simuna/build/php4-STABLE-200208170600/main/internal_functions.c:80: first defined here
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/.libs/libxslt.al(sablot.lo): In function `zm_startup_xslt':
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/sablot.c:154: multiple definition of `SXPF_DISPOSE_VALUES'
main/.libs/libmain.al(internal_functions.lo):/usr/src/simuna/build/php4-STABLE-200208170600/main/internal_functions.c:80: first defined here
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/.libs/libxslt.al(sablot.lo): In function `zm_startup_xslt':
/usr/src/simuna/build/php4-STABLE-200208170600/ext/xslt/sablot.c:154: multiple definition of `SXPF_SUPPORTS_UNPARSED_ENTITIES'
main/.libs/libmain.al(internal_functions.lo):/usr/src/simuna/build/php4-STABLE-200208170600/main/internal_functions.c:80: first defined here
collect2: ld returned 1 exit status
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/usr/src/simuna/build/php4-STABLE-200208170600'
make: *** [all-recursive] Error 1


When compiling with:  ./configure --prefix=/smn/wbs/php4 --with-apxs2=/smn/wbs/bin/apxs --with-dom --enable-wddx --enable-static --enable-mbstring --enable-mailparse --with-ldap --enable-ftp --with-curl --with-bz2 --with-zlib --with-openssl --without-pear --with-mysql --enable-xslt --with-xslt-sablot --with-xslt-salot-js --with-config-file-path=/smn/wbs/conf --with-gd --enable-gd-native-ttf




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-17 10:06 UTC] pisi at pisitek dot com
And the problem exists with sablotron 0.95 only. Works fine with sablotron 0.90
 [2002-08-17 10:10 UTC] kalowsky@php.net
Moving to Apache2.  Please realize Apache2 support is extremely experimental at this point.
 [2002-08-17 13:04 UTC] markonen@php.net
Sablotron 0.95 introduced an API change that is not backwards-compatible with earlier versions. We've decided to retain the old API for the STABLE branch (4.2.x) and support Sablotron 0.95 from 4.3.0 onwards.

You can either downgrade to Sablotron 0.90 or start using 4.3.0-dev via the non-STABLE snapshots at snaps.php.net.
 [2002-08-17 15:13 UTC] pisi at pisitek dot com
as ov php4-200208170900 from snaps.php.net the problem still remains.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 19:01:26 2019 UTC