|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18877 Failed to write session data
Submitted: 2002-08-13 06:08 UTC Modified: 2002-10-18 01:00 UTC
Avg. Score:4.5 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: cristian at myp dot ad Assigned:
Status: No Feedback Package: Session related
PHP Version: 4.2.2 OS: Linux PS2 2.2.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: cristian at myp dot ad
New email:
PHP Version: OS:


 [2002-08-13 06:08 UTC] cristian at myp dot ad
I have some trouble with the session mangement.
I am getting that error when I try to create a session

[13-Aug-2002 12:01:07] PHP Warning:  write failed: Invalid argument (22) in Unknown on line 0
[13-Aug-2002 12:01:07] PHP Warning:  Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

but it creates the file correctly.
When I try to modify that file in other page I get the same error and it do anything in the session file in tmp.

The permissions in my tmp directory are: 

drwxrwxrwt    2 root     root         4096 Aug 13 09:54 tmp

I tried the 4.2.2 and the snap versions and i get the same error.

Please can you help me ??


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-13 10:10 UTC]
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit

Thank you for your interest in PHP.

 [2002-08-14 07:44 UTC] cristian at myp dot ad
My configure is: 
./configure --with-apache=../apache_1.3.26 --with-mysql=/usr/local 
I tried with the same configure and the same php.ini with other versions 
and in 4.1.2 i get the same result but in 4.0.6 it works fine. 
I think this is a bug in versions newer than php 4.0.6
 [2002-08-14 12:04 UTC]
Can you please provide a sample script and the session section of your php.ini file?
 [2002-08-19 08:59 UTC] cristian at myp dot ad
This is the session section of my php.ini: 
; Handler used to store/retrieve data. 
session.save_handler = files 
; Argument passed to save_handler.  In the case of files, this is the path 
; where data files are stored. Note: Windows users have to change this 
; variable in order to use PHP's session functions. 
session.save_path = /tmp 
; Whether to use cookies. 
session.use_cookies = 1 
; Name of the session (used as cookie name). = PHPSESSID 
; Initialize session on request startup. 
session.auto_start = 0 
; Lifetime in seconds of cookie or, if 0, until browser is restarted. 
session.cookie_lifetime = 0 
; The path for which the cookie is valid. 
session.cookie_path = / 
; The domain for which the cookie is valid. 
session.cookie_domain = 
; Handler used to serialize data.  php is the standard serializer of PHP. 
session.serialize_handler = php 
; Percentual probability that the 'garbage collection' process is started 
; on every session initialization. 
session.gc_probability = 1 
; After this number of seconds, stored data will be seen as 'garbage' and 
; cleaned up by the garbage collection process. 
session.gc_maxlifetime = 1440 
; Check HTTP Referer to invalidate externally stored URLs containing ids. 
; HTTP_REFERER has to contain this substring for the session to be 
; considered as valid. 
session.referer_check = 
; How many bytes to read from the file. 
session.entropy_length = 0 
; Specified here to create the session id. 
session.entropy_file = 
;session.entropy_length = 16 
;session.entropy_file = /dev/urandom 
; Set to {nocache,private,public} to determine HTTP caching aspects. 
session.cache_limiter = nocache 
; Document expires after n minutes. 
session.cache_expire = 180 
; use transient sid support if enabled by compiling with 
session.use_trans_sid = 1 
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry" 
And here  a sample of the code I am using. 
        if (!isset($llenguaActual)) { 
 [2002-08-19 09:15 UTC]
I'm unable to reproduce.  You realize that A) session vars aren't written until you move to the next page, and B) register_globals is off now in PHP, right?

 [2002-08-19 09:31 UTC] cristian at myp dot ad
I have Register_Globals=on 
And when I access the page it creates the session file fine, but I get the 
errors in the logfile, and when  try to update the session data it does 
anything and I get the errors. 
Is a linux on a Playstation 2 with kernel 2.2.1 for PS2.
 [2002-08-22 07:29 UTC] phpbugs at mx4k dot com

same problem here.
 [2002-08-22 08:05 UTC]

I ran into this trouble too. Usually, the session file is totally empty at the end of the page. It may also be totally erased, but this was much rarer, and may not be linked.

Yet, I think I found a workaround : 

I register a shutdown_function, and in this function, I do a sessions_write_close().

This made my life a lot better, and may point the place where the bugs live. 

function page_end(){

 [2002-10-02 01:23 UTC]
Please give the current HEAD CVS a try. Many session issues, most likely yours as well, have been addressed over the last few days.

 [2002-10-02 06:20 UTC]
Please try using this CVS snapshot:
For Windows:

 [2002-10-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 22:01:28 2024 UTC