php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18843 Search Result flaw
Submitted: 2002-08-10 08:20 UTC Modified: 2002-12-14 10:48 UTC
From: patric at liefdeis dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: 4.2.2 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: patric at liefdeis dot com
New email:
PHP Version: OS:

 

 [2002-08-10 08:20 UTC] patric at liefdeis dot com
I was searching for 'case sensitive', and saw this in the fopen() manual (in search result, that short part of the file):

--
If filename begins with "http://www.php.net/manual/en/function.fopen.php#AEN24371">case sensitive), an HTTP 1.0
--

But when you open the file, it says:

--
 If filename begins with "http://" (not case sensitive), an HTTP 1.0
--

With other words, the Search Engine likes rewriting 

--
http://" (not 
--

to

--
http://www.php.net/manual/en/function.fopen.php#AEN24371">
--

For no reason at all! It is kind of enoying :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-14 10:48 UTC] goba@php.net
The "not" word was there in a previous version of the documentation (indexed by the search engine). The #AEN... part is simply the nearest anchor in the document upwards, so if you click on the word in the search result, you get to the nearest part of the page... => This is not a bug...
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 00:05:52 2023 UTC