|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1884 .htaccess error / pcfg_openfile problem
Submitted: 1999-07-26 15:30 UTC Modified: 2002-06-16 08:35 UTC
From: jbaach at mediathek dot de Assigned:
Status: Not a bug Package: Other
PHP Version: 3.0.11 OS: Linux (SuSe 5.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jbaach at mediathek dot de
New email:
PHP Version: OS:


 [1999-07-26 15:30 UTC] jbaach at mediathek dot de
I sent this message yesterday to the mailinglist (US and German):

I  am/was trying to upgrade my LAMP Server on my SuSE 5.2 Linux Box from
Apache 1.2.6, PHP 3.0,.... to

Apache 1.3.6 with
    PHP 3.0.11 with

Everything compiles fine, and even the Servers runs. The problem is that
whenever I configure some <Directory ...>  AllowOverride all
</Directory>, these can only be accessed when there is a .htaccess file
located in the directory. If there is not one, I get an "403 Error", and
I get a line telling me something like

......[crit] .. /home..../.htaccess pcfg_openfile: unable tho check
htaccessfile, ensure it is readable

This happens whenever there is _no_ .htaccess file in the directory.
This is also true for directories which do not contain any index files,
but are allowed for indexing (Options Indexes).

I tried many configurations during the last hours, and this problem even
occours with the httpd.conf file that is installed by the 'make install'
after compiling the apache.

I found (in the apache bug base) that there was some similar mistake
with older versions of apache (1.3.2), but the patches that were
mentioned there do not fit to the apache 1.3.6 code (which does not
surprise me too much ;-).

##### Workaround #######

After 6 hours of testing (rebuilding php and apache) I found out that whenever the libmcrypt is compiled with php, this error occours. I tried libmcrypt v. 2.0 and 2.2.1. Without this library the server works fine.

---------PHP do-conf-------
CFLAGS='-O2 -I/usr/local/openssl/include' ./configure
--with-mysql=/usr/local/mysql/current --with-msql
--with-pdflib=/usr/local --with-zlib --enable-sysvshm=yes
--enable-sysvsem=yes --with-config-file-path=/etc
--enable-track-vars=yes --with-mcrypt --enable-url-includes --with-mhash

------Apache configure with-----
SSL_BASE=/usr/local/openssl ./configure --prefix=/usr/local/apache/1.3.6
 --enable-module=ssl \
 --activate-module=src/modules/php3/libphp3.a \
 --enable-module=php3 \
 --activate-module=src/modules/auth_mysql/libauth_mysql.a \
 --enable-module=log_referer \


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:35 UTC]
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 [2003-11-16 14:46 UTC] phptom at wordesign dot net
I got the same problem with php 4.3.4 and libmcrypt.

I am going to try to add a new bug.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 16:01:28 2024 UTC