php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1875 Segmentation fault (11) when i use include() or require()
Submitted: 1999-07-26 08:50 UTC Modified: 1999-07-26 15:41 UTC
From: andres at stallion dot ee Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Beta 1 OS: RedHat Linux 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andres at stallion dot ee
New email:
PHP Version: OS:

 

 [1999-07-26 08:50 UTC] andres at stallion dot ee
PHP4b1 running as module(--with-apxs=/usr/sbin/apxs --with-mysql --with-session=/tmp --enable-sysvsem=yes --enable-sysvshm=yes --with-zlib --enable-track-vars=yes) on Apache 1.3.6 

When i use function include("real_file.inc") or require("real_file.inc") no output  on browser. From apache errorlog i can see [notice] child pid 19446 exit signal Segmentation fault (11).

Sample:

(index.phtml)
<?include("real_file.inc");?>


(real_file.inc)
<?echo "blahh"?>



So and when i try run this script(index.phtml) no output on browser.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-26 15:41 UTC] rasmus at cvs dot php dot net
You need Apache-1.3.7 for this to work properly.  You can get a cvs snapshot from
http://dev.apache.org/from-cvs/apache-1.3/
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC