php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18716 Errors, Crash when loading DLL's
Submitted: 2002-08-02 17:45 UTC Modified: 2002-08-20 07:55 UTC
Votes:7
Avg. Score:5.0 ± 0.0
Reproduced:7 of 7 (100.0%)
Same Version:7 (100.0%)
Same OS:7 (100.0%)
From: rrobinson at cormix dot info Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.2 OS: Windows 2000 SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rrobinson at cormix dot info
New email:
PHP Version: OS:

 

 [2002-08-02 17:45 UTC] rrobinson at cormix dot info
When ever we try to load dll's on our Apache 2 test server, it gives the following error, with the appropriate dir in front of the dll name.

Unable to load dynamic library 'C:\PHP\extensions/php_mssql.dll' - The specified module could not be found.'

We have checked many times to make sure that all the files are available and that the links are correct, but it still gives the error.

Here is the config line for the extensions:

extension_dir = "C:\PHP\extensions"

And that IS where they are located.

Please reply ASAP.

Thank you in advance.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-02 17:49 UTC] rrobinson at cormix dot info
I forgot to mention that PHP does work, when there are no extensions loading. And the problem is not just for MSSQL, but for all extensions.
 [2002-08-02 19:01 UTC] sniper@php.net
..and you have followed the instructions in install.txt?
And copied all the necessary bundled dlls into your path?
And you have mssql client dlls installed in your system?

 [2002-08-02 19:11 UTC] rrobinson at cormix dot info
Yes, I have followed all of the driections from the install.txt file.

I made sure that php_mssql.dll is in the /extensions/ dir, and that php
 [2002-08-02 19:13 UTC] rrobinson at cormix dot info
(Sorry, full post here)

Yes, I have followed all of the driections from the install.txt file.

I made sure that php_mssql.dll is in the \extensions\ dir, and that php4ts.dll is in the \WINDOWS\SYSTEM32\ dir.

Also, PHP runs just fine when I am not trying to use any extensions.
 [2002-08-20 07:55 UTC] edink@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

This is probably problem in your install. My guess is that you forgot to copy content of dlls folder from php distribution into your c:\winnt\system32. php_mssql.dll needs ntwdblib.dll which is located in that dir.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 08:03:58 2023 UTC