php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18692 libmodphp4 not found during apache configure; fix found, doc'd here.
Submitted: 2002-08-01 16:55 UTC Modified: 2002-08-01 19:18 UTC
From: flavoie at students dot depaul dot edu Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.2.2 OS: Linux 2.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: flavoie at students dot depaul dot edu
New email:
PHP Version: OS:

 

 [2002-08-01 16:55 UTC] flavoie at students dot depaul dot edu
Configured with:
./configure --with-mysql --with-apache=../apache_1.3.26 --enable-track-vars
make, make install produce no fatal errors.

sapi/modules/apache copied over to src/modules/php4
(which I had to mkdir manually- not actually mentioned in docs that this had to be done or be named php4 vs php)..

when configuring apache 1.3.26 via mod_ssl-2.8.10, 
./configure 
  --with-apache=../apache_1.3.26
  --with-ssl=../open_ssl-0.9.6e
  --activate-module=src/modules/php4/libphp4.a
  --activate-module=src/modules/perl/libperl.a
  --enable-module=php4 --enable-module=perl
  --enable-module=ssl --enable-shared=ssl
  --enable-module=so

...and the test-make fails because it can't find -lmodphp4.
This became a many-houred hair-pulling event since libmodphp4.a or .so could not be found as a file, and references to it were in the php configure scripts.

Final solution idea came from http://www.iodbc.org/iodbc-phposxHOWTO.html which mentioned:
"If you get an error that libmodphp4.a is out of date:
cd src/modules/php4 
ranlib libmodphp4.a
"

Sure enough, I ranlib'd where specified, and the file was created with abosultely no fanfare, and configuration via mod_ssl continued, completed, and everything was happy ever more. Except me, I lost 4 hours of sleep.

Since what I suspect the real problem is, is that the changes made to the apache configure template APACI thing made by php got trounced by mod_ssl, and so when apache builds everything, it has no directives to build libmodphp4.

Could it not be built when php builds? Could php's mucking with the apache configure be changed so that this kind of trouncing doesn't happen? Would it really hurt to mention this kinda stuff in the documentation? It *would* help if the online docs pages weren't a disorganized forum of install tribulations.

-Tony, otherwise known as Cryptomancer




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-01 19:18 UTC] sniper@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 05:01:31 2024 UTC