php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18679 Form data invisible
Submitted: 2002-07-31 14:42 UTC Modified: 2002-07-31 14:45 UTC
From: Dodecha at psykopat dot com Assigned:
Status: Not a bug Package: *Data Exchange functions
PHP Version: 4.2.2 OS: Slackware 8.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Dodecha at psykopat dot com
New email:
PHP Version: OS:

 

 [2002-07-31 14:42 UTC] Dodecha at psykopat dot com
I have made a script that reveices data from a html form, and stores it in a mysql database.
But php stores empty feilds in mysql, and the script prints out empty feilds where it's supposed to echo the data on the web page, but i can see the data in my browsers address line. 
I have tried with post and get, there seems to be no difference in the results...

This same script used to work in slack 8.0.

i've reinstalled apache, php and mysql with no luck

my versions are:
Apache/1.3.26
mysql-3.23.51 (binary dist.)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-31 14:45 UTC] nohn@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 [2002-07-31 14:49 UTC] Dodecha at psykopat dot com
Sorry for causing any inconvenience, the problem was
caused by the register_globals = Off in php.ini...

thanks anyway
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 25 18:01:28 2019 UTC