php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18669 FTP functions fail under Sambar Server
Submitted: 2002-07-31 10:05 UTC Modified: 2002-07-31 17:46 UTC
From: jg at themail dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.2.2 OS: Windows XP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jg at themail dot com
New email:
PHP Version: OS:

 

 [2002-07-31 10:05 UTC] jg at themail dot com
    I have some problems with PHP and the Sambar FTP server. I am intending to create a FTP indexer script using PHP, the problem is while accedding it:

<?php
 $iFTP=ftp_connect("localhost", 21, 2);
 ftp_login($iFTP, "anonymous", "kk@kk.com");
 ftp_pasv($iFTP, TRUE);
 $asListado=ftp_rawlist($iFTP, "/");
 for ($iCont=0; $iCont<count($asListado); $iCont++)
 {
  print($asListado[$iCont] . "<br>\n");
 }
 ftp_close($iFTP);
?>

    The script works fine while retrieving the directory list of other FTP server, but while accedding Sambar FTP server, it fails.

    Any hints?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-31 17:46 UTC] kalowsky@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 08:03:35 2021 UTC