php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18637 Error reporting problem
Submitted: 2002-07-30 04:42 UTC Modified: 2002-07-30 18:09 UTC
From: amarsh at names dot co dot uk Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.2 OS: Redhat Linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: amarsh at names dot co dot uk
New email:
PHP Version: OS:

 

 [2002-07-30 04:42 UTC] amarsh at names dot co dot uk
Error reporting seems to be working in the reverse way to which it should e.g.

error_reporting = E_ALL & ~E_NOTICE

still displays all notices but

error_reporting = E_ALL & E_NOTICE

does NOT display notices.

Just had fun for the past few hours trying to get this sorted on my new machine!

Have not tried any other error settings but considering that in the php.ini error comments it is specified that

error_reporting = E_ALL & ~E_NOTICE

will show all errors EXCEPT notices and that isn't actually the case, that definitely constitutes a bug.

I did scour the bug listings first but could not find any mention of this.

I have PHP running as an Apache dynamic module.

Warm Regards

Ant

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-30 04:48 UTC] rasmus@php.net
Unable to reproduce here.  Works perfectly fine in my 4.2.2.  Suspect user error.
 [2002-07-30 05:00 UTC] amarsh at names dot co dot uk
How can it be a user error when it is the php.ini file I'm editing?!?!?! It's not a script that I'm trying to run....

Here is my exact setup:

Redhat Linux 7.3
Apache 1.3.26
PHP 4.2.2 (as dynamic module)
mod_ssl 2.8.10
openssl 0.9.6d

My PHP configure call was:

./configure --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-track-vars

Ant
 [2002-07-30 05:05 UTC] rasmus@php.net
Well, clue #1 is that you don't seem to understand the & operator. E_ALL & E_NOTICE makes no sense whatsoever.  So I am guessing you are confused about other bits too.  I looked at the code, it hasn't changed in ages and this has always worked.  I could of course be wrong, but given that nobody else has reported this and if this was broken we'd get thousands of questions, my conclusion is that this is specific to your server.
 [2002-07-30 06:36 UTC] amarsh at names dot co dot uk
Unfortunately I don't have time to continue with this - let's just put it down to something specific to my setup.

My real point is that:

error_reporting = E_ALL & ~E_NOTICE

does not do what is suggested.

What's particularly important however is that I'm now getting the error messages I expected.

Feel free to close/delete this "bug" entry.

Warm Regards

Ant
 [2002-07-30 18:09 UTC] sniper@php.net
You're definately doing something wrong as I'm also
unable to reproduce this. 

error_reporting = E_ALL & ~E_NOTICE

will print all errors except notices..

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 20:05:44 2022 UTC