php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18622 MSSQL Fetch_Array and fetch_Object not working propely
Submitted: 2002-07-29 10:17 UTC Modified: 2002-09-11 11:48 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ferreira at unicid dot br Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.2.2 OS: Linux 2.4 / Win2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ferreira at unicid dot br
New email:
PHP Version: OS:

 

 [2002-07-29 10:17 UTC] ferreira at unicid dot br
MSSQL Fetch_Array and fetch_Object not working propely

Sometimes works , sometimes not

mssqy_fetch_array($tb)

$tb["fieldname"]; -> works sometimes
$tb[0]; -> works always

mssqy_fetch_object($tb)

$tb->fieldname; -> works sometimes


both worked fine with php 4.21

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-11 20:00 UTC] dsit at cox dot net
At first, I was beginning to question the php script, but after seeing this, I realized that the script I have been using for 7 months may not be the issue.  Our server was upgraded from 4.2.1 to 4.2.2 and has caused intermittent problems since.  I loaded 4.2.2 on my dev server and was able to reproduce the outcome.  I then removed 4.2.2 from the dev server and was unable to reporduce the error.
 [2002-08-11 20:23 UTC] kalowsky@php.net
4.2.2 didn't have any changes done to the MSSQL system at all.  It was really a security patch for HTTP POSTs only.  If it worked under 4.2.1 it should work just fine under 4.2.2, unless the POST is somehow not.

Can you post a simple sample script to show/reproduce this behavior?
 [2002-09-11 11:48 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 21 16:03:35 2022 UTC