php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18615 --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2
Submitted: 2002-07-28 17:35 UTC Modified: 2002-07-28 22:16 UTC
From: thought at phenomind dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.2.2 OS: Linux 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thought at phenomind dot com
New email:
PHP Version: OS:

 

 [2002-07-28 17:35 UTC] thought at phenomind dot com
Installing php4.2.2 on two identically configured Linux 7.2 servers. Both php compilations crash at the same point with same error.

Configuration line is:

./configure --with-apxs=/usr/local/apachestronghold/bin/apxs --with-oci=/usr/local/oracle/OraHome1

configure program crashes saying:

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... configure: error: Use --with-apxs2 with Apache 2.x!

--

Stronghold 3 definitely running Apache 1.3.22 see http://212.137.27.66/

If I use --with-apxs2 like it suggests, which I know is wrong, the installation fails when running make (not a surprise)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-28 17:39 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
 [2002-07-28 17:51 UTC] thought at phenomind dot com
Got snapshot php4-STABLE-200207281200.tar.gz and the 
problem still exists in that.

I have tried old version php-4.1.2 and that is fine on the 
server. Something is still broken --with-apxs in the php4-
STABLE-200207281200 snapshot. 

Thanks for speedy reply.
 [2002-07-28 17:55 UTC] thought at phenomind dot com
I maybe being an idiot here; I didn't see the php4-STABLE-
latest.tar.gz

I'm going to try that now.
 [2002-07-28 18:01 UTC] thought at phenomind dot com
php4-STABLE-latest.tar.gz is the same as php4-STABLE-
200207281200.tar.gz (for now!) so problem definitely still 
exists.

Thanks.
 [2002-07-28 18:45 UTC] sniper@php.net
Hmm..I really think it's fixed..can you try this snapshot:

http://snaps.php.net/php4-latest.tar.gz

(it's 4.3.0-dev, the fix might not have been merged to the stable branch)

 [2002-07-28 20:22 UTC] thought at phenomind dot com
Yep. It is fixed in that. I need this for production 
servers so I'll wait until it goes stable first.

Thanks ever so much for your help. You guys do a great 
job!!!
 [2002-07-28 22:16 UTC] sniper@php.net
This should now be fixed also in the stable branch.

Please try the latest of STABLE snapshots..make sure
the date in acinclude.m4 (first line) is 2002/07/29 02:15:18


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jul 02 06:05:44 2022 UTC