php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18595 variables not shown
Submitted: 2002-07-26 11:34 UTC Modified: 2002-07-26 11:35 UTC
From: mh at ccmconsult dot de Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.0 OS: w2k server iis5 german sp2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mh at ccmconsult dot de
New email:
PHP Version: OS:

 

 [2002-07-26 11:34 UTC] mh at ccmconsult dot de
Content of script test.php:
<?php
print 'Hi!';
print '<br>';
print 'QueryString: ' . $QUERY_STRING . '<br>';
print 'A: ' . $A . '<br>';
print 'Bye!';
print '<br>';
?>
<p>
<a href="test.php?A=B">test.php with parameter a = b </A>

After klicking on the link, no variable contents are displayed. What?s wrong ? If only have this symptom on W2K server  with iis5. On my development workstation (w2k german iis sp2) everything works fine (php also detects an error if you call the script without parameters. on the server no error msg comes up.) 

Thanks in advance !
Michael

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-26 11:35 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 09:03:49 2022 UTC