php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18584 exit signal Segmentation fault (11)
Submitted: 2002-07-26 01:00 UTC Modified: 2002-08-30 01:00 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: webmaster at dodge-diesel dot org Assigned:
Status: No Feedback Package: Reproducible crash
PHP Version: 4.2.2 OS: Red Linux 7.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: webmaster at dodge-diesel dot org
New email:
PHP Version: OS:

 

 [2002-07-26 01:00 UTC] webmaster at dodge-diesel dot org
Once in a while I'm getting seg faults while running YaBB forums on my site.  So it appears anyway.  The site will delay for a long time, then give a seg fault every few minutes.  The results of my debug are below:  

Program received signal SIGSEGV, Segmentation fault.
0x4207fa78 in strcmp () from /lib/i686/libc.so.6
(gdb) bt
#0  0x4207fa78 in strcmp () from /lib/i686/libc.so.6
#1  0x08091e1b in pcre_get_compiled_regex ()
#2  0x08092348 in pcre_get_compiled_regex ()
#3  0x08092685 in zif_preg_match ()
#4  0x08112dab in execute ()
#5  0x08112f65 in execute ()
#6  0x08112f65 in execute ()
#7  0x08112f65 in execute ()
#8  0x080f8c16 in zend_execute_scripts ()
#9  0x0807d599 in php_execute_script ()
#10 0x08100526 in apache_php_module_main ()
#11 0x0807a8f8 in php_restore_umask ()
#12 0x0807a951 in php_restore_umask ()
#13 0x0811c4c7 in ap_invoke_handler ()
#14 0x0813102b in ap_some_auth_required ()
#15 0x0813108c in ap_process_request ()
#16 0x08128095 in ap_child_terminate ()
#17 0x08128240 in ap_child_terminate ()
#18 0x081283b4 in ap_child_terminate ()
#19 0x08128a2c in ap_child_terminate ()
#20 0x0812928f in main ()
#21 0x42017499 in __libc_start_main () from /lib/i686/libc.so.6
(gdb)

ANY IDEAS???  Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-26 01:48 UTC] rverlander@php.net
Hmm Well I have compiled PHP 4.2.x fine under Red Hat 7.3 a few times, but the default gcc in RH7.3 often links stuff wrong, try downgrading gcc to egcs 1.1.2 (also known as gcc 2.91)
What Apache version?
And are you using a non-standard glibc?
 [2002-07-26 02:01 UTC] rverlander@php.net
Umm because you have a @dodge-diesel.org e-mail address I decided to go to http://uptime.netcraft.com/up/graph?site=www.dodge-diesel.org and it said: The site www.dodge-diesel.org is running Apache/1.3.14 (Unix) (Red-Hat/Linux) PHP/4.1.0 mod_perl/1.23 on Linux

Please upgrade to the latest versions of Apache, PHP and mod_perl.
 [2002-07-26 02:05 UTC] webmaster at dodge-diesel dot org
Hello and thanks for the quick responses.  I am running this on a dev server which will replace my old one.  The one I'm having problems with is running apache 1.3.26 with php version 4.2.2, so it's not the production dodge-diesel.org server. :)  Thanks.
 [2002-07-26 02:07 UTC] rverlander@php.net
Hmm Is PHP static linked or DSO (APXS)?
 [2002-07-26 02:11 UTC] rverlander@php.net
(Note: When I say static linked I don't mean linked with static glibc, i mean linked into Apache source code)
 [2002-07-26 02:14 UTC] webmaster at dodge-diesel dot org
Well I'm not the smartest cat about this so I'll post my configure statements.

For php:

./configure --with-mysql --with-apache=../apache_1.3.26 --enable-track-vars 

For Apache:

./configure --sysconfdir=/etc/httpd/conf  --activate-module=src/modules/php4/libphp4.a --logfiledir=/home/log --datadir=/home/httpd

My php info can be seen here:

http://64.244.30.243/phpinfo.php

It says with-zlib but I took that out last time.  Don't know why it still shows up in the info, but it's not on or installed.  Thanks :)
 [2002-07-26 02:16 UTC] rverlander@php.net
Thats a static.

Try these Apache/PHP configures:

Apache:
./configure --enable-module=so --enable-module=rewrite --enable-module=userdir
make
make install

PHP:
./configure --with-apxs=/usr/local/apache/bin/apxs --with-gd=/usr --with-zlib=/usr --enable-sockets --with-mysql
 [2002-07-26 02:17 UTC] rverlander@php.net
Oops I mean:

PHP:
./configure --with-apxs=/usr/local/apache/bin/apxs --with-gd=/usr
--with-zlib=/usr --enable-sockets --with-mysql
make
make install
 [2002-07-26 02:28 UTC] webmaster at dodge-diesel dot org
Thanks for the info.  apache compiles ok but when I try php I get this:

Sorry, I was not able to successfully run APXS.  Possible reasons:

1.  Perl is not installed;
2.  Apache was not compiled with DSO support (--enable-module=so);
3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs
The output of /usr/local/apache/bin/apxs follows
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting


I know I'm missing something
 [2002-07-26 02:31 UTC] rverlander@php.net
Did you use that **exact** PHP/Apache configures?
 [2002-07-26 02:36 UTC] webmaster at dodge-diesel dot org
Yeah I did.  I have perl in there, it works fine.  Forgive my ignorance here, and thank you for the help.
 [2002-07-26 02:36 UTC] webmaster at dodge-diesel dot org
hehe, I mean perl works fine, not the php configure the way you told me.
 [2002-07-26 02:37 UTC] rverlander@php.net
huh?
 [2002-07-26 02:41 UTC] webmaster at dodge-diesel dot org
I just meant that the php ./configure statement you gave me doesn't work.  I typed it in exactly.  The apache one worked though and compiled ok.
 [2002-07-26 02:53 UTC] webmaster at dodge-diesel dot org
Ok I redid my apache with yours and mine, then I did the php like you said, and this is what I get.

stub.lo: file not recognized: File truncated
collect2: ld returned 1 exit status
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/home/engineer/installs/php-4.2.2'
make: *** [all-recursive] Error 1
 [2002-07-26 03:18 UTC] webmaster at dodge-diesel dot org
OK, thanks for the help.  I got it all compiled right, but still the seg fault.  I think I'll call it a night.
 [2002-07-26 06:33 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


This looks like something that was fixed already, but try
get us a better backtrace. No need to change to DSO from static. Just read the instructions given in above URL.

Also, if you could try and find out what kind of script causes this crash it would help a lot too..(maybe ask other YaBB users/author?)

 [2002-07-26 09:54 UTC] webmaster at dodge-diesel dot org
My backtraces are the same every time I try it, unless I'm missing something.  This problem is still not fixed.
 [2002-07-26 10:46 UTC] sniper@php.net
hint: --enable-debug (read the instructions, please)

 [2002-07-26 11:09 UTC] webmaster at dodge-diesel dot org
This is supposed to be support, not a guessing game.  If you look at the first post in this bug report, you'll see that I've already gone through that (--enable-debug).  Unless I'm missing something else, the information you're asking for is as the top of the thread.
 [2002-07-26 11:10 UTC] derick@php.net
"You get what you pay for." We're all volunteers and most have a job besides this.
 [2002-07-26 11:32 UTC] jtate@php.net
Derick, his very first post included a back trace.  He says that all his back traces are the same.
 [2002-07-26 11:49 UTC] jtate@php.net
Ok, for running RH 7.3, this is my suggestion.

Install the latest apache RPM's from the RedHat update site.  You'll especially need the apache-devel package.  If the rpm will install, then you can be sure that you've got everything that you need to get PHP working.

Then try configuring php again:
./configure --with-apxs --with-gd --with-mysql --enable-track-vars

It should find everything it needs to compile correctly.

If it doesn't work, configure with --enable-debug and post another back trace.

Then we'll be able to better track down the problem.
 [2002-07-26 13:18 UTC] webmaster at dodge-diesel dot org
Man this is getting old :)  I can't even install the rpm.  I get page read errors when doing it.  I can't even do an rpm -qa without getting errors.  Maybe it's time to go back to 6.2, geez.
 [2002-07-26 14:14 UTC] jtate@php.net
Before you do that, do a rpm --rebuilddb.  That should rebuild your Install Database so that you don't get errors.

Do you get errors on installing the RPM, or on page views after installing the RPM?
 [2002-07-26 14:40 UTC] webmaster at dodge-diesel dot org
When I try rpm --rebuilddb I get this:

 rpm --rebuilddb
/usr/lib/rpm/rpmd: relocation error: /usr/lib/librpmdb-4.0.4.so: undefined symbol:


That's what happens to me when I try to do anything in rpm.  This is a brand new install of 7.3 too.
 [2002-07-26 14:50 UTC] jtate@php.net
Looks like you need to get ahold of your local LUG for some help.  I don't know how to fix that.
 [2002-07-26 16:56 UTC] webmaster at dodge-diesel dot org
Yep, I think so.  I just tried 6.2 but since I have a P4, it doesn't play well with anaconda.  SO, I'm off to try 7.2  I hope this one works.  It seems that everything I did in 7.3 was broken.  You know you have problems with rpm doesn't work "out of the box" so to speak.  Thanks for trying guys.  I'll let you know what I find out.
 [2002-07-26 19:36 UTC] webmaster at dodge-diesel dot org
Ok here is something odd.  I take out the shtml parsing stuff from httpd.conf and guess what?  No more seg faults.  Must be how apache is working with php and shtml or something.  I don't know for sure if that's the answer, but so far I've gone an hour without a single fault.  Soon as I put shtml handlers back in, it faults within 2-3 minutes.
 [2002-07-28 02:22 UTC] webmaster at dodge-diesel dot org
Well, I don't know why, but the shtml parser was causing the faults.  Since I don't need shtml anyway, I took it out and all is good.  This DOES sound like a bug with either php or apache to me though.  Hope you all can get it fixed.  Probably doesn't occur too often.
 [2002-07-29 11:27 UTC] jtate@php.net
Hmm.  See if you have short_open_tag turned on in your php.ini file.  If PHP is invoked to parse an shtml file, that could cause serious problems.  See http://www.php.net/manual/en/configuration.php looking for short_open_tag for how to turn off short open tags.
 [2002-08-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Mar 04 20:01:31 2024 UTC