php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18577 ocilogon hangs
Submitted: 2002-07-25 19:08 UTC Modified: 2002-07-26 03:48 UTC
From: vc8432 at sbc dot com Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.2.2 OS: aix 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vc8432 at sbc dot com
New email:
PHP Version: OS:

 

 [2002-07-25 19:08 UTC] vc8432 at sbc dot com
I'm running aix4.3.3 with oracle8.1.7, and apache 1.3.26 with php4.2.2
ocilogon is hanging the browser and leaving a attempted connection to oracle hanging around eating up CPU
I'm out of ideas for debugging this problem.  I actually don't even know where to start now.  Interestingly enough, I have a development machine with the same OS, DB and apache and it works fine.  The main difference is that the node with problems is an SP node with the other being a stand alone node.  I'm at a loss to determine what the problem is.  Any help with debug methods would make me damn happy.

my configures....
./configure --without-mysql --with-apache=/macs/apache --with-oci8 --enable-track-vars
./configure --prefix=/macs/apache --activate-module=src/modules/php4/libphp4.a

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-26 01:54 UTC] rverlander@php.net
Try either:

PHP linked via APXS instead of staticly

or

PHP as a CGI
 [2002-07-26 02:09 UTC] vc8432 at sbc dot com
Thanks for replying
I'm kind of stuck with the static installation.  I think.  We are just migrating from db2 to oracle and I need to minimize the conversion effort for the development team.  i.e.  must keep the interface the same.  Any Ideas on how I can debug this?
 [2002-07-26 02:24 UTC] derick@php.net
compile php with the --enable-sigchild and see if that fixes the problem.

Derick
 [2002-07-26 03:48 UTC] vc8432 at sbc dot com
seems it was a problem with the oracle installation
re-installed oracle and no longer have the problem

Thanks for your help!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 03:05:45 2022 UTC