php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18561 configure fails to find imap libs
Submitted: 2002-07-25 06:47 UTC Modified: 2002-07-25 08:02 UTC
From: oden dot eriksson at kvikkjokk dot net Assigned:
Status: Closed Package: IMAP related
PHP Version: 4CVS-2002-07-25 OS: Mandrake Linux 8.2 (and 9.0)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: oden dot eriksson at kvikkjokk dot net
New email:
PHP Version: OS:

 

 [2002-07-25 06:47 UTC] oden dot eriksson at kvikkjokk dot net
Hi.

Whatever I pass to "--with-imap-ssl" I still get:

checking for IMAP support... yes, shared
checking for pam_start in -lpam... yes
checking for crypt in -lcrypt... (cached) yes
checking whether SSL libraries are needed for c-client... /usr/lib
checking whether IMAP works... configure: error: build test failed. Please check the config.log for details.


Ecerpts from config.log:

configure:34909: checking whether SSL libraries are needed for c-client
configure:35069: checking whether IMAP works
configure:35102: gcc -o conftest -O3 -fomit-frame-pointer -pipe  -march=i686 -mcpu=i686 -ffast-math 
-fno-strength-reduce -fPIC   conftest.c  -lcrypt -lpam -lgd -lt1 -lfreetype -lpng -lz -ljpeg -lcrypt -lssl 
-lcrypto -lresolv -lm -ldl -lttf -lfreetype -lpng -ljpeg -lz -lnsl -lreadline -lhistory -lncurses -lcrypt 
1>&5
/tmp/cclSaiiI.o: In function `main':
/tmp/cclSaiiI.o(.text+0x31): undefined reference to `mail_open'
collect2: ld returned 1 exit status
configure: failed program was:
#line 35077 "configure"
#include "confdefs.h"

    void mm_log(void){}
    void mm_dlog(void){}
    void mm_flags(void){}
    void mm_fatal(void){}
    void mm_critical(void){}
    void mm_nocritical(void){}
    void mm_notify(void){}
    void mm_login(void){}
    void mm_diskerror(void){}
    void mm_status(void){}
    void mm_lsub(void){}
    void mm_list(void){}
    void mm_exists(void){}
    void mm_searched(void){}
    void mm_expunged(void){}
    char mail_open();
    int main() {
      mail_open(0,"",0);
      return 0;
    }




Reverting to ext/imap/config.m4 (v1.44) fixes the problem.

Chears.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-25 07:03 UTC] sniper@php.net
What was the full configure line used?
Have you tried compiling it as static, not shared extension?

 [2002-07-25 07:06 UTC] sniper@php.net
I think I have a fix for this..just a moment..I need to test it first.

 [2002-07-25 07:31 UTC] oden dot eriksson at kvikkjokk dot net
#!/bin/sh

export MYFLAGS="-O3 -fomit-frame-pointer -pipe  -march=`uname -m` -mcpu=`uname -m` -ffast-math 
-fno-strength-reduce"
export CFLAGS="$MYFLAGS -fPIC"
export LIBS="-lttf -lfreetype -lpng -ljpeg -lz -lnsl -lreadline -lhistory -lncurses"
export EXTENSION_DIR="/usr/local/php4/lib/php/extensions"
export IMAP_SHARED_LIBADD="-lc-client -lssl -lcrypto"
export PROG_SENDMAIL="/var/qmail/bin/usendmail"

if ! [ -f ./configure ]; then ./buildconf; fi

./configure \
--prefix=/usr/local/php4 \
--with-exec-dir=/usr/local/php4/bin \
--sysconfdir=/etc \
--with-apxs2=/usr/sbin/apxs2 \
--with-layout=GNU \
--with-config-file-path=/etc/httpd2/conf \
--with-openssl=shared,/usr \
--enable-magic-quotes \
--disable-rpath \
--enable-force-cgi-redirect \
--enable-track-vars \
--disable-debug \
--enable-pic \
--enable-inline-optimization \
--enable-bcmath=shared,/usr \
--with-hyperwave=shared \
--with-unixODBC=shared,/usr \
--enable-shmop=shared \
--with-zlib=shared,/usr \
--without-aspell \
--with-bz2=shared,/usr \
--with-jpeg-dir=shared,/usr \
--with-tiff-dir=shared,/usr \
--with-curl=shared,/usr \
--enable-dba=shared,/usr \
--with-gdbm=shared,/usr \
--with-db3=shared,/usr \
--with-cdb=shared,/usr \
--enable-dbx=shared,/usr \
--enable-dio=shared,/usr \
--with-gd=shared,/usr \
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-ttf=shared,/usr \
--with-freetype-dir=shared,/usr \
--with-t1lib=shared,/usr \
--enable-gd-native-ttf \
--with-gettext=shared,/usr \
--with-gmp=shared,/usr \
--with-imap=shared,/usr \
--with-imap-ssl \
--with-ldap=shared,/usr \
--with-mcrypt=shared,/usr \
--with-mhash=shared,/usr \
--enable-mime_magic=shared,/usr \
--with-ming=shared,/usr \
--with-mysql=shared,/usr \
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-tiff-dir=shared,/usr \
--with-pgsql=shared,/usr \
--with-pspell=shared,/usr \
--with-recode=shared,/usr \
--with-snmp=shared,/usr \
--enable-ucd-snmp-hack \
--with-regex=php \
--enable-sockets=shared \
--enable-sysvmsg=shared \
--enable-sysvsem=shared \
--enable-sysvshm=shared \
--enable-ftp=shared \
--enable-calendar=shared \
--enable-tokenizer=shared \
--enable-session=shared \
--enable-posix=shared \
--enable-overload=shared \
--enable-ctype=shared \
--enable-yp=shared \
--with-expat-dir=shared,/usr \
--with-xmlrpc=shared,/usr \
--with-zip=shared,/usr \
--with-vpopmail=shared,/home/vpopmail \
--enable-pcre=shared,/usr \
--with-dom=shared,/usr \
--with-dom-xslt=shared,/usr \
--with-dom-exslt=shared,/usr \
--with-readline=shared,/usr \
--enable-shared
 [2002-07-25 07:34 UTC] sniper@php.net
Fixed now in CVS. btw. You don't need to export IMAP_SHARED_LIBADD...it works fine without doing that.

 [2002-07-25 08:02 UTC] oden dot eriksson at kvikkjokk dot net
It seems to work now, the SSL symbols are in-place too.

As you suggested I removed the "IMAP_SHARED_LIBADD" stuff and it also worked.

Great thanks Sniper!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 01:03:36 2022 UTC