php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18522 Make install error in php-4.2.2
Submitted: 2002-07-24 01:40 UTC Modified: 2002-07-24 19:23 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: fabian at crystone dot se Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.2.2 OS: Redhat 7.2 i386
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fabian at crystone dot se
New email:
PHP Version: OS:

 

 [2002-07-24 01:40 UTC] fabian at crystone dot se
Hi!

I have tryed to install the new php pakage without success. I have tryed 2 systems with redhat 7.2 i386, the error comes when i try to do make install as u se bellow. I have read some mails from the php-mailinglist and iam not the only with this problem. I never had problems with compiling php and this may be a bug in the new php version 4.2.2

Best regards
Fabian

[activating module `php4' in /usr/local/apache-1.3.26-new/conf/httpd.conf]
cp libs/libphp4.so /usr/local/apache-1.3.26-new/libexec/libphp4.so
cp: cannot stat `libs/libphp4.so': No such file or directory
apxs:Break: Command failed with rc=1
make[1]: *** [install-sapi] Error 1
make[1]: Leaving directory `/home/admin/compile/php-4.2.2'
make: *** [install-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-24 01:58 UTC] fabian at crystone dot se
Hi i forgot my configure here it comes

./configure --with-mysql --with-apxs=/usr/local/apache-1.3.26-new/bin/apxs --with-config-file-path=/usr/local/php-4.2.2 --prefix=/usr/local/php-4.2.2 --disable-debug --enable-pic --disable-rpath --enable-inline-optimization --with-bz2 --with-gd --with-gdbm --with-gettext --with-jpeg-dir=/usr --with-mm --with-openssl --with-png --with-regex ./configure --with-mysql --with-apxs=/usr/local/apache-1.3.26-new/bin/apxs --with-config-file-path=/usr/local/php-4.2.2 --prefix=/usr/local/php-4.2.2 --disable-debug --enable-pic --disable-rpath --enable-inline-optimization --with-bz2 --with-gd --with-gdbm --with-gettext --with-jpeg-dir=/usr --with-mm --with-openssl --with-png --with-regex=system --with-tff --with-zlib --with-layout=GNU --enable-bcmath --enable-debugger --disable-ftp --enable-magic-quotes --disable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-yp --enable-wddx --without-oracle --without-oci8 --with-pspell --with-xml
 [2002-07-24 19:23 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

(for 4.2.2, just create libs/ directory and do 'make && make install)

 [2002-08-02 10:01 UTC] benites at cs dot unca dot edu
I grabbed php4-STABLE-200207311200 off snaps.php.net. and it compiled cleanly. When I did the make install, I got the same error as the first poster. There was a "libs" directory. 

Did I do something wrong?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 05:01:28 2024 UTC